# CVE-2026-49993: @nuxt/webpack-builder and @nuxt/rspack-builder dev server same-origin check bypassed when Sec-Fetch-Site, Origin, and Referer are all absent (incomplete fix for GHSA-6m52-m754-pw2g)

> Attackers can steal source code from Nuxt dev servers bound to non-loopback addresses by bypassing same-origin checks when specific headers are absent.

- **Severity:** Medium 5.9 (`CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** GHSA-x6qj-4h56-5rj5

## What is CVE-2026-49993?

CVE-2026-49993 is a medium-severity vulnerability in nuxt, published on 12 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Nuxt is an open-source web development framework for Vue.js. In @nuxt/rspack-builder and @nuxt/webpack-builder from versions 3.15.4 to before 3.21.7 and 4.0.0 to before 4.4.7, there is an incomplete fix for GHSA-6m52-m754-pw2g. Source code may still be stolen during dev when using the webpack / rspack builder if the dev server is bound to a non-loopback address (e.g. nuxt dev --host) and the developer opens a malicious site on the same network. This issue has been patched in versions 3.21.7 and 4.4.7.

Weakness: CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2026-49993?

8 open source packages ship an affected version, including @nuxt/rspack-builder and @nuxt/webpack-builder. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nuxt/rspack-builder` | npm | From 3.15.4 | 3.21.7 |
| `@nuxt/rspack-builder` | npm | From 3.15.4 | 3.21.7 |
| `@nuxt/rspack-builder` | npm | From 4.0.0 | 4.4.7 |
| `@nuxt/rspack-builder` | npm | From 4.0.0 | 4.4.7 |
| `@nuxt/webpack-builder` | npm | From 3.15.4 | 3.21.7 |
| `@nuxt/webpack-builder` | npm | From 3.15.4 | 3.21.7 |
| `@nuxt/webpack-builder` | npm | From 4.0.0 | 4.4.7 |
| `@nuxt/webpack-builder` | npm | From 4.0.0 | 4.4.7 |

Products: Nuxt Nuxt\/Rspack-Builder, Nuxt Nuxt\/Webpack-Builder.

## How do I fix CVE-2026-49993?

Upgrade @nuxt/rspack-builder to a fixed version for your release line: 3.21.7 or 4.4.7.

## Is CVE-2026-49993 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49993 exists.

## Other vulnerabilities in nuxt

- [CVE-2026-45670](https://insights.sbomify.com/CVE-2026-45670/): Nuxt: Dev server exposes built source over LAN to malicious sites (incomplete fix for GHSA-4gf7-ff8x-hq99) (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49993 and fix it if it is affected.

What it is: CVE-2026-49993 is a medium-severity vulnerability in nuxt, published on 12 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49993 exists.

Affected packages and fixed versions:
- @nuxt/rspack-builder (npm): affected from 3.15.4; fixed in 3.21.7
- @nuxt/rspack-builder (npm): affected from 3.15.4; fixed in 3.21.7
- @nuxt/rspack-builder (npm): affected from 4.0.0; fixed in 4.4.7
- @nuxt/rspack-builder (npm): affected from 4.0.0; fixed in 4.4.7
- @nuxt/webpack-builder (npm): affected from 3.15.4; fixed in 3.21.7
- @nuxt/webpack-builder (npm): affected from 3.15.4; fixed in 3.21.7
- @nuxt/webpack-builder (npm): affected from 4.0.0; fixed in 4.4.7
- @nuxt/webpack-builder (npm): affected from 4.0.0; fixed in 4.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49993/ (Markdown: https://insights.sbomify.com/CVE-2026-49993/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49993
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49993
- OSV: https://osv.dev/vulnerability/CVE-2026-49993

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49993/
Summaries are generated and may contain mistakes; the official description above is the record.
