# CVE-2026-49995: Tautulli: Stored Cross-Site Scripting (XSS) in the newsletter

> An attacker with API access can inject malicious scripts into the newsletter configuration, leading to script execution when an administrator views the settings.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-r6pg-vqxj-v75j

## What is CVE-2026-49995?

CVE-2026-49995 is a medium-severity cross-site scripting vulnerability in Tautulli, published on 21 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Tautulli is a Python based monitoring and tracking tool for Plex Media Server. Prior to 2.17.2, the newsletter cron field stored in the newsletters table is inserted by data/interfaces/default/newsletter_config.html into a JavaScript string without safe JSON encoding. An administrator or caller with the Tautulli API key can store a crafted cron value, and an administrator who later opens the newsletter configuration modal passively triggers script execution in the Tautulli web context. The stored value persists in the database and can continue to execute after credential rotation until it is removed. This issue is fixed in version 2.17.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-49995?


## How do I fix CVE-2026-49995?

No fix has been published for CVE-2026-49995 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-49995 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49995 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-49995 and fix it if it is affected.

What it is: CVE-2026-49995 is a medium-severity cross-site scripting vulnerability in Tautulli, published on 21 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-49995 exists.

Affected product: Tautulli. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-49995/ (Markdown: https://insights.sbomify.com/CVE-2026-49995/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-49995
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-49995
- OSV: https://osv.dev/vulnerability/CVE-2026-49995

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-49995/
Summaries are generated and may contain mistakes; the official description above is the record.
