{"answers":{"affected":"3 open source packages ship an affected version, including parse-server and parse.","exploited":"There is no known exploitation of CVE-2026-50008 in the wild and no public exploit code.","fix":"Upgrade parse-server to 9.9.1-alpha.3 or later.","what":"CVE-2026-50008 is a medium-severity vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-50008 and fix it if it is affected.\n\nWhat it is: CVE-2026-50008 is a medium-severity vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-50008 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected from 9.8.0; fixed in 9.9.1-alpha.3\n- parse-server (npm): affected from 9.8.0; fixed in 9.9.1-alpha.3\n- parse (Bitnami): affected from 9.8.0; fixed in 9.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-50008/ (Markdown: https://insights.sbomify.com/CVE-2026-50008/index.md)","id":"CVE-2026-50008","markdown":"https://insights.sbomify.com/CVE-2026-50008/index.md","name":"CVE-2026-50008","record":{"aliases":["BIT-parse-2026-50008","GHSA-p84r-h6rx-f2xr"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Parse Server backend","requires_auth":"none","summary":"Attackers can bypass the routeAllowList security feature by sending batch sub-requests, accessing restricted API routes despite authentication controls.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. From version 9.8.0 to before version 9.9.1-alpha.3, the routeAllowList server option restricts external client access to a configured list of REST API routes. The check is only enforced as Express middleware against the outer HTTP request URL, so the /batch handler dispatches each sub-request to the internal router without re-running the allow-list check. An external caller whose outer route matches batch can issue batch sub-requests to any REST API route that the operator omitted from the allow-list. Authentication, ACL, CLP, and other inner-route authorization controls still apply — only the operator-configured route firewall is bypassed. This issue has been patched in version 9.9.1-alpha.3.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server: Server option routeAllowList is bypassable through batch sub-requests","id":"CVE-2026-50008","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Netty QUIC stateless reset token material exposed through header-visible connection IDs","id":"CVE-2026-50009"},"packages":[{"ecosystem":"Bitnami","fixed":["9.9.1"],"introduced":["9.8.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2026-50008"},{"ecosystem":"npm","fixed":["9.9.1-alpha.3"],"introduced":["9.8.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-p84r-h6rx-f2xr"},{"ecosystem":"npm","fixed":["9.9.1-alpha.3"],"introduced":["9.8.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-p84r-h6rx-f2xr"}],"prev":{"headline":"Actual: Shared users can perform owner-only file management actions","id":"CVE-2026-50007"},"products":["parse-server"],"published":"2026-06-12","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-12","vendors":["parse-community"]},"summary":"Attackers can bypass the routeAllowList security feature by sending batch sub-requests, accessing restricted API routes despite authentication controls.","url":"https://insights.sbomify.com/CVE-2026-50008/"}