# CVE-2026-50008: Parse Server: Server option routeAllowList is bypassable through batch sub-requests

> Attackers can bypass the routeAllowList security feature by sending batch sub-requests, accessing restricted API routes despite authentication controls.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** BIT-parse-2026-50008, GHSA-p84r-h6rx-f2xr

## What is CVE-2026-50008?

CVE-2026-50008 is a medium-severity vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. From version 9.8.0 to before version 9.9.1-alpha.3, the routeAllowList server option restricts external client access to a configured list of REST API routes. The check is only enforced as Express middleware against the outer HTTP request URL, so the /batch handler dispatches each sub-request to the internal router without re-running the allow-list check. An external caller whose outer route matches batch can issue batch sub-requests to any REST API route that the operator omitted from the allow-list. Authentication, ACL, CLP, and other inner-route authorization controls still apply — only the operator-configured route firewall is bypassed. This issue has been patched in version 9.9.1-alpha.3.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-50008?

3 open source packages ship an affected version, including parse-server and parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | From 9.8.0 | 9.9.1-alpha.3 |
| `parse-server` | npm | From 9.8.0 | 9.9.1-alpha.3 |
| `parse` | Bitnami | From 9.8.0 | 9.9.1 |

## How do I fix CVE-2026-50008?

Upgrade parse-server to 9.9.1-alpha.3 or later.

## Is CVE-2026-50008 being exploited?

There is no known exploitation of CVE-2026-50008 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50008 and fix it if it is affected.

What it is: CVE-2026-50008 is a medium-severity vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50008 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected from 9.8.0; fixed in 9.9.1-alpha.3
- parse-server (npm): affected from 9.8.0; fixed in 9.9.1-alpha.3
- parse (Bitnami): affected from 9.8.0; fixed in 9.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50008/ (Markdown: https://insights.sbomify.com/CVE-2026-50008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50008
- OSV: https://osv.dev/vulnerability/CVE-2026-50008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50008/
Summaries are generated and may contain mistakes; the official description above is the record.
