# CVE-2026-50009: Netty QUIC stateless reset token material exposed through header-visible connection IDs

> An on-path attacker can derive stateless reset tokens from exposed connection IDs to launch Denial of Service attacks against Netty QUIC servers.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** CLEANSTART-2026-BZ13456, CLEANSTART-2026-RK84860, CLEANSTART-2026-VH61636, DEBIAN-CVE-2026-50009, ECHO-ac1d-f0e0-27f6, GHSA-cq4q-cv5g-r8q5, MINI-3mrx-q688-qxvc, MINI-8g35-hx63-h266, MINI-984g-mphv-68x7, MINI-j75v-466p-82fv, MINI-pvjm-2g4m-xq6h, MINI-v4qc-jf39-4whx, MINI-x2px-pq3x-97p9, MINI-xxx2-825r-cqm2, UBUNTU-CVE-2026-50009

## What is CVE-2026-50009?

CVE-2026-50009 is a medium-severity vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is a network application framework for development of protocol servers and clients. Prior to version 4.2.15.Final, Netty QUIC exposes the stateless reset token on the network path when using the default HMAC-based connection-ID and stateless-reset-token generators. The reset token for the server's current source connection ID can be derived from bytes that appear as the connection ID in QUIC headers after a source-CID rotation. An on-path attacker observing the headers can use the token to perform a Denial of Service by sending a spoofed Stateless Reset packet. Version 4.2.15.Final patches the issue.

Weakness: CWE-330 (Use of Insufficiently Random Values), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-50009?

2 open source packages ship an affected version, including io.netty:netty-codec-classes-quic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-classes-quic` | Maven | From 4.2.0.Final | 4.2.15.Final |
| `io.netty:netty-codec-classes-quic` | Maven | From 4.2.0.Final | 4.2.15.Final |

Products: Netty Netty.

## How do I fix CVE-2026-50009?

Upgrade io.netty:netty-codec-classes-quic to 4.2.15.Final or later.

## Is CVE-2026-50009 being exploited?

There is no known exploitation of CVE-2026-50009 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50009 and fix it if it is affected.

What it is: CVE-2026-50009 is a medium-severity vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50009 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-classes-quic (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final
- io.netty:netty-codec-classes-quic (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50009/ (Markdown: https://insights.sbomify.com/CVE-2026-50009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50009
- OSV: https://osv.dev/vulnerability/CVE-2026-50009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50009/
Summaries are generated and may contain mistakes; the official description above is the record.
