CVE-2026-50010 Netty's wrapping plain trust manager silently disables hostname verification
Netty library bypasses hostname verification when using plain trust managers, allowing man-in-the-middle attacks against TLS connections.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-50010?
CVE-2026-50010 is a high-severity vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netty is a network application framework for development of protocol servers and clients. Prior to versions 4.1.135.Final and 4.2.15.Final, SimpleTrustManagerFactory.engineGetTrustManagers() and related paths wrap any user-supplied plain X509TrustManager in X509TrustManagerWrapper, which extends X509ExtendedTrustManager but implements the 3-arg checkServerTrusted(chain, authType, SSLEngine) by discarding the SSLEngine and calling the 2-arg delegate. Because the object now IS an X509ExtendedTrustManager, neither SunJSSE's internal AbstractTrustManagerWrapper nor Netty's own OpenSslX509TrustManagerWrapper will re-wrap it to add endpoint-identification. Consequently, even though Netty 4.2 sets endpointIdentificationAlgorithm="HTTPS" by default, a client built with `SslContextBuilder.forClient().trustManager(somePlainX509TrustManager)` performs no hostname verification at all. Versions 4.1.135.Final and 4.2.15.Final patch the issue.
Weakness: CWE-347
Which versions are affected by CVE-2026-50010?
4 open source packages ship an affected version, including io.netty:netty-handler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty-handler Maven | All versions | 4.1.135.Final |
io.netty:netty-handler Maven | All versions | 4.1.135.Final |
io.netty:netty-handler Maven | From 4.2.0.Final | 4.2.15.Final |
io.netty:netty-handler Maven | From 4.2.0.Final | 4.2.15.Final |
Products include Netty Netty.
How do I fix CVE-2026-50010?
Upgrade io.netty:netty-handler to a fixed version for your release line: 4.1.135.Final or 4.2.15.Final.
Is CVE-2026-50010 being exploited?
There is no known exploitation of CVE-2026-50010 in the wild and no public exploit code.
Other vulnerabilities in Netty Netty
- CVE-2026-75595 Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
- CVE-2026-75596 Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing
- CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
- CVE-2026-55851 Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
- CVE-2026-56745 Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion
Sources
Also known as CLEANSTART-2026-FZ21134, CLEANSTART-2026-LR71963, CLEANSTART-2026-ND17109, CLEANSTART-2026-NN05980, CLEANSTART-2026-ZY02566, DEBIAN-CVE-2026-50010 and 128 more.