# CVE-2026-50015: pnpm: Arbitrary File Write/Delete via Malicious Patch File (Path Traversal)

> Attackers can write or delete arbitrary files via malicious patch files during pnpm install, potentially leading to code execution.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-rxhj-4m44-96r4, MINI-vjgq-m5gq-8882, ROOT-APP-NPM-CVE-2026-50015

## What is CVE-2026-50015?

CVE-2026-50015 is a high-severity path traversal vulnerability in pnpm, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to 10.34.0 and 11.4.0, pnpm's patch application pipeline (@pnpm/patch-package) performs no path validation on file paths extracted from .patch files. An attacker who contributes a malicious patch file via a pull request can write attacker-controlled content to or delete arbitrary files on the filesystem during pnpm install, as the user running the install. The diff --git header paths containing ../../ sequences traverse out of the package directory, and the traversal is difficult to catch in code review because patch file diff headers are opaque to most reviewers. This vulnerability is fixed in 10.34.0 and 11.4.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-50015?

4 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.34.0 |
| `pnpm` | npm | All versions | 10.34.0 |
| `pnpm` | npm | From 11.0.0 | 11.4.0 |
| `pnpm` | npm | From 11.0.0 | 11.4.0 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-50015?

Upgrade pnpm to a fixed version for your release line: 10.34.0 or 11.4.0.

## Is CVE-2026-50015 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50015 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50015 and fix it if it is affected.

What it is: CVE-2026-50015 is a high-severity path traversal vulnerability in pnpm, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50015 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.34.0
- pnpm (npm): affected all versions; fixed in 10.34.0
- pnpm (npm): affected from 11.0.0; fixed in 11.4.0
- pnpm (npm): affected from 11.0.0; fixed in 11.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50015/ (Markdown: https://insights.sbomify.com/CVE-2026-50015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50015
- OSV: https://osv.dev/vulnerability/CVE-2026-50015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50015/
Summaries are generated and may contain mistakes; the official description above is the record.
