# CVE-2026-50016: pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement

> A malicious registry package can use path traversal in dependency aliases to replace project files with symlinks, potentially leading to code execution or data modification.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-hwx4-2j3j-g496, MINI-575j-vrf4-7vp8, ROOT-APP-NPM-CVE-2026-50016

## What is CVE-2026-50016?

CVE-2026-50016 is a high-severity path traversal vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to 10.34.0 and 11.4.0, pnpm allows a transitive dependency alias from registry package metadata to contain path traversal segments. During install, pnpm later uses that alias as a filesystem path when linking dependency nodes. As a result, a registry package can cause `pnpm install --ignore-scripts` to replace paths in the current project with symlinks to attacker-controlled dependency package directories. This vulnerability is fixed in 10.34.0 and 11.4.0.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-50016?

4 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.34.0 |
| `pnpm` | npm | All versions | 10.34.0 |
| `pnpm` | npm | From 11.0.0 | 11.4.0 |
| `pnpm` | npm | From 11.0.0 | 11.4.0 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-50016?

Upgrade pnpm to a fixed version for your release line: 10.34.0 or 11.4.0.

## Is CVE-2026-50016 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50016 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)
- [CVE-2025-69262](https://insights.sbomify.com/CVE-2025-69262/): pnpm vulnerable to Command Injection via environment variable substitution (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50016 and fix it if it is affected.

What it is: CVE-2026-50016 is a high-severity path traversal vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50016 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.34.0
- pnpm (npm): affected all versions; fixed in 10.34.0
- pnpm (npm): affected from 11.0.0; fixed in 11.4.0
- pnpm (npm): affected from 11.0.0; fixed in 11.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50016/ (Markdown: https://insights.sbomify.com/CVE-2026-50016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50016
- OSV: https://osv.dev/vulnerability/CVE-2026-50016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50016/
Summaries are generated and may contain mistakes; the official description above is the record.
