# CVE-2026-50017: pnpm binds unscoped user-level npm auth credentials to a repository-selected registry

> pnpm leaks user-level npm authentication tokens to attacker-controlled registries specified in repository configuration files.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** GHSA-cjhr-43r9-cfmw, MINI-hm45-363c-25rc, ROOT-APP-NPM-CVE-2026-50017

## What is CVE-2026-50017?

CVE-2026-50017 is a medium-severity vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to 10.34.0 and 11.4.0, pnpm can send user-level unscoped npm authentication credentials to a registry chosen by a repository-local .npmrc file. In the reproduced case, the user's npm config contains a default registry and an unscoped _authToken. The repository does not provide a token-bearing auth line. It only sets registry= to a different registry URL. During normal pnpm metadata/install workflows, pnpm binds the user-origin unscoped credential to the repository-selected registry and sends it as an Authorization header. This vulnerability is fixed in 10.34.0 and 11.4.0.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-50017?

4 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.34.0 |
| `pnpm` | npm | All versions | 10.34.0 |
| `pnpm` | npm | From 11.0.0 | 11.4.0 |
| `pnpm` | npm | From 11.0.0 | 11.4.0 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-50017?

Upgrade pnpm to a fixed version for your release line: 10.34.0 or 11.4.0.

## Is CVE-2026-50017 being exploited?

There is no known exploitation of CVE-2026-50017 in the wild and no public exploit code.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50017 and fix it if it is affected.

What it is: CVE-2026-50017 is a medium-severity vulnerability in pnpm, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-50017 in the wild and no public exploit code.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.34.0
- pnpm (npm): affected all versions; fixed in 10.34.0
- pnpm (npm): affected from 11.0.0; fixed in 11.4.0
- pnpm (npm): affected from 11.0.0; fixed in 11.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50017/ (Markdown: https://insights.sbomify.com/CVE-2026-50017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50017
- OSV: https://osv.dev/vulnerability/CVE-2026-50017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50017/
Summaries are generated and may contain mistakes; the official description above is the record.
