# CVE-2026-50022: Metacat acts as unintended proxy to backend Apache SOLR engine

> Unauthenticated attackers can exploit Metacat to proxy requests to the backend Solr engine, disclosing internal configuration files and enabling infrastructure profiling.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-57g5-qq6w-7jr8

## What is CVE-2026-50022?

CVE-2026-50022 is a medium-severity server-side request forgery vulnerability in NCEAS metacat, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Metacat is data repository software that helps researchers preserve, share, and discover data. Prior to 3.4.2, MetacatSolrIndex.query forwards the client-controlled qt parameter through Apache SolrJ from search endpoints such as /d1/mn/v2/query/solr/ to its privileged Solr backend. An unauthenticated client can select the /admin/file handler, and SolrJ reformats the parameter into a request accepted even when handleSelect=false is configured on Solr 7.0 or later. When Solr returns the selected core configuration file, Metacat embeds the raw content in an XML processing error response, disclosing internal files such as solrconfig.xml and enabling infrastructure profiling. This issue is fixed in version 3.4.2.

Weakness: CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2026-50022?


## How do I fix CVE-2026-50022?

No fix has been published for CVE-2026-50022 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-50022 being exploited?

There is no known exploitation of CVE-2026-50022 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50022 and fix it if it is affected.

What it is: CVE-2026-50022 is a medium-severity server-side request forgery vulnerability in NCEAS metacat, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50022 in the wild and no public exploit code.

Affected product: NCEAS metacat. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50022/ (Markdown: https://insights.sbomify.com/CVE-2026-50022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50022
- OSV: https://osv.dev/vulnerability/CVE-2026-50022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50022/
Summaries are generated and may contain mistakes; the official description above is the record.
