# CVE-2026-50023: yt-dlp: Dangerous file type creation via insufficient filename sanitization (Bypass of CVE-2024-38519)

> Remote attackers can write malicious OS shortcut files to the user's filesystem, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-50023, GHSA-c6mh-fpjc-4pr3, PYSEC-2026-3430, UBUNTU-CVE-2026-50023

## What is CVE-2026-50023?

CVE-2026-50023 is a high-severity vulnerability in yt-dlp, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

yt-dlp is a command-line audio/video downloader. Prior to 2026.06.09, a vulnerability exists in yt-dlp that allows a remote attacker to write arbitrary OS-shortcut files (such as .desktop, .url, .webloc) to the user's filesystem, bypassing the remediation for CVE-2024-38519. The allowlist explicitly included the unsafe extensions .desktop, .url, and .webloc so that the functionality of the --write-link option (and its variants) could be preserved. These allowlist inclusions can be exploited by an attacker to write malicious OS-shortcut files in the context of a media or subtitles download. This vulnerability is fixed in 2026.06.09.

Weakness: CWE-641 (Improper Restriction of Names for Files and Other Resources)

## Which versions are affected by CVE-2026-50023?

3 open source packages ship an affected version, including yt-dlp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yt-dlp` | PyPI | All versions | 2026.6.9 |
| `yt-dlp` | PyPI | All versions | 2026.6.9 |
| `yt-dlp` | PyPI | All versions | 2026.6.9 |

Products: Yt-Dlp Project Yt-Dlp.

## How do I fix CVE-2026-50023?

Upgrade yt-dlp to 2026.6.9 or later.

## Is CVE-2026-50023 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50023 exists.

## Other vulnerabilities in yt-dlp

- [CVE-2026-26331](https://insights.sbomify.com/CVE-2026-26331/): yt-dlp: Arbitrary Command Injection when using the `--netrc-cmd` option (high 8.8)
- [CVE-2024-22423](https://insights.sbomify.com/CVE-2024-22423/): yt-dlp `--exec` command injection when using `%q` in yt-dlp on Windows (high 8.4)
- [CVE-2023-40581](https://insights.sbomify.com/CVE-2023-40581/): yt-dlp command injection when using `%q` in `--exec` on Windows (high 8.4)
- [CVE-2026-50574](https://insights.sbomify.com/CVE-2026-50574/): yt-dlp: Arbitrary code execution via manifest downloads with aria2c (high 8.3)
- [CVE-2026-55404](https://insights.sbomify.com/CVE-2026-55404/): yt-dlp: Downstream command injection via improper sanitization of yt-dlp --write-link output (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50023 and fix it if it is affected.

What it is: CVE-2026-50023 is a high-severity vulnerability in yt-dlp, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50023 exists.

Affected packages and fixed versions:
- yt-dlp (PyPI): affected all versions; fixed in 2026.6.9
- yt-dlp (PyPI): affected all versions; fixed in 2026.6.9
- yt-dlp (PyPI): affected all versions; fixed in 2026.6.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50023/ (Markdown: https://insights.sbomify.com/CVE-2026-50023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50023
- OSV: https://osv.dev/vulnerability/CVE-2026-50023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50023/
Summaries are generated and may contain mistakes; the official description above is the record.
