# CVE-2026-5006: Vault Vulnerable to Privilege Escalation via Slash Injection in Templated Policy Paths

> Authenticated attackers can escalate privileges and access unauthorized paths by injecting slashes into templated policy paths in HashiCorp Vault.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** BIT-vault-2026-5006, GHSA-5h48-5rrm-m3c8, MINI-jw35-qv72-pw83

## What is CVE-2026-5006?

CVE-2026-5006 is a medium-severity vulnerability in HashiCorp Vault, published on 24 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was identified in HashiCorp Vault and Vault Enterprise (“Vault”) such that an authenticated attacker may manipulate an identity value referenced by a templated policy path to gain unintended access to Vault paths.

An attacker who can control the referenced identity value may include slash ({{/}}) characters that Vault interprets as additional path segments when rendering the policy.

This vulnerability, CVE-2026-5006, was fixed in Vault Community Edition 2.0.4 and Vault Enterprise 2.0.4, 1.21.9, 1.20.14, and 1.19.20.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-5006?

1 open source package ship an affected version, including vault.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vault` | Bitnami | From 0.11.0 | 2.0.4 |

## How do I fix CVE-2026-5006?

Upgrade vault to 2.0.4 or later.

## Is CVE-2026-5006 being exploited?

There is no known exploitation of CVE-2026-5006 in the wild and no public exploit code.

Public exploit code:

- https://github.com/tcollins-hashicorp/vault-cve-2026-5006-audit (github_poc): https://github.com/tcollins-hashicorp/vault-cve-2026-5006-audit

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5006 and fix it if it is affected.

What it is: CVE-2026-5006 is a medium-severity vulnerability in HashiCorp Vault, published on 24 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-5006 in the wild and no public exploit code.

Affected packages and fixed versions:
- vault (Bitnami): affected from 0.11.0; fixed in 2.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5006/ (Markdown: https://insights.sbomify.com/CVE-2026-5006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5006
- OSV: https://osv.dev/vulnerability/CVE-2026-5006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5006/
Summaries are generated and may contain mistakes; the official description above is the record.
