# CVE-2026-50132: Budibase: Chat Identity Link Hijacking via Missing Consent & CSRF — Account Impersonation in Budibase

> Attackers can hijack chat identity links via CSRF, silently binding victim accounts to attacker-controlled external identities without consent.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 29 Jun 2026
- **Also known as:** GHSA-v7j5-vc4m-723w

## What is CVE-2026-50132?

CVE-2026-50132 is a high-severity vulnerability in budibase, published on 26 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Budibase is an open-source low-code platform. Prior to 3.39.0, `GET /api/chat-links/:instance/:token/handoff` is a public endpoint (no auth required) that performs a permanent, state-changing operation: it binds an external chat identity (Slack/Discord/MS Teams) to an authenticated Budibase user account, with no consent UI and no CSRF protection. The session token in the URL is created by the attacker (from their own /link slash command) and embeds the attacker's externalUserId. When an authenticated Budibase victim visits the URL, their account is silently and permanently linked to the attacker's Slack/Discord identity. The server responds with "Authentication succeeded." — no indication of what was linked. This vulnerability is fixed in 3.39.0.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-50132?

2 open source packages ship an affected version, including @budibase/server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@budibase/server` | npm | All versions | 3.39.0 |
| `@budibase/server` | npm | All versions | 3.39.0 |

Products: Budibase Budibase.

## How do I fix CVE-2026-50132?

Upgrade @budibase/server to 3.39.0 or later.

## Is CVE-2026-50132 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50132 exists.

## Other vulnerabilities in budibase

- [CVE-2026-54350](https://insights.sbomify.com/CVE-2026-54350/): Budibase: Anonymous NoSQL operator injection via published-app query templates (critical 10.0)
- [CVE-2026-27702](https://insights.sbomify.com/CVE-2026-27702/): Budibase Vulnerable to Remote Code Execution via Unsafe eval() in View Filter Map Function (Budibase Cloud) (critical 9.9)
- [CVE-2026-54352](https://insights.sbomify.com/CVE-2026-54352/): Budibase: Arbitrary file read by workspace-builder via PWA-zip symlink upload (critical 9.6)
- [CVE-2026-31818](https://insights.sbomify.com/CVE-2026-31818/): Budibase: Server-Side Request Forgery via REST Connector with Empty Default Blacklist (critical 9.6)
- [CVE-2026-30240](https://insights.sbomify.com/CVE-2026-30240/): Budibase PWA ZIP Upload Path Traversal Allows Reading Arbitrary Server Files Including All Environment Secrets (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50132 and fix it if it is affected.

What it is: CVE-2026-50132 is a high-severity vulnerability in budibase, published on 26 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50132 exists.

Affected packages and fixed versions:
- @budibase/server (npm): affected all versions; fixed in 3.39.0
- @budibase/server (npm): affected all versions; fixed in 3.39.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50132/ (Markdown: https://insights.sbomify.com/CVE-2026-50132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50132
- OSV: https://osv.dev/vulnerability/CVE-2026-50132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50132/
Summaries are generated and may contain mistakes; the official description above is the record.
