CVE-2026-50149 Contour has Improper JWT Verification for Non-SNI Requests on Virtual Hosts with Fallback Certificate Enabled
Attackers can bypass JWT authentication on Contour ingress controllers by sending requests without SNI when fallback certificates are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-50149?
CVE-2026-50149 is a medium-severity authentication bypass vulnerability in projectcontour contour, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Contour is a Kubernetes ingress controller using Envoy proxy. In versions 1.23.0 through 1.33.4, when an `HTTPProxy` is configured with incompatible combination of both `.spec.virtualhost.tls.enableFallbackCertificate: true` and `.spec.virtualhost.jwtProviders`, Contour does not reject the configuration. Consequently, requests from clients that do not send TLS SNI or send an unrecognized SNI (one that does not match any `HTTPProxy` FQDN) bypass configured JWT verification and are proxied to upstream services without a valid token. This issue is fixed in Contour v1.33.5. Contour now rejects and marks invalid any `HTTPProxy` resources that combine `.spec.virtualhost.tls.enableFallbackCertificate: true` with `.spec.virtualhost.jwtProviders`. Affected resources will receive a status condition with the error reason `TLSIncompatibleFeatures`. As a workaround, do not enable `.spec.virtualhost.tls.enableFallbackCertificate` on `HTTPProxy` resources that also define `.spec.virtualhost.jwtProviders`. Remove one of the two settings to avoid the invalid configuration.
Weakness: CWE-295
Which versions are affected by CVE-2026-50149?
4 open source packages ship an affected version, including github.com/projectcontour/contour and contour.
| Package | Affected | Fixed in |
|---|---|---|
github.com/projectcontour/contour Go | From 1.23.0 | 1.33.5 |
github.com/projectcontour/contour Go | From 1.23.0 | 1.33.5 |
github.com/projectcontour/contour Go | From 1.23.0 | 1.33.5 |
contour Bitnami | From 1.23.0 | 1.33.5 |
How do I fix CVE-2026-50149?
Upgrade github.com/projectcontour/contour to 1.33.5 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-50149 being exploited?
There is no known exploitation of CVE-2026-50149 in the wild and no public exploit code.
Sources
Also known as BIT-contour-2026-50149, CLEANSTART-2026-CU86688, CLEANSTART-2026-QS30975, GHSA-g3xr-5w5j-w4q4, GO-2026-5889, MINI-8c86-xp9h-x62r and 5 more.