# CVE-2026-50149: Contour has Improper JWT Verification for Non-SNI Requests on Virtual Hosts with Fallback Certificate Enabled

> Attackers can bypass JWT authentication on Contour ingress controllers by sending requests without SNI when fallback certificates are enabled.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** BIT-contour-2026-50149, CLEANSTART-2026-CU86688, CLEANSTART-2026-QS30975, GHSA-g3xr-5w5j-w4q4, GO-2026-5889, MINI-8c86-xp9h-x62r, MINI-8hf3-vcp9-9p77, MINI-jxrx-qxwf-wprr, MINI-p7m5-7459-r6cf, MINI-w5hg-56v9-g7c9, MINI-x25m-j4r2-65rx

## What is CVE-2026-50149?

CVE-2026-50149 is a medium-severity authentication bypass vulnerability in projectcontour contour, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Contour is a Kubernetes ingress controller using Envoy proxy. In versions 1.23.0 through 1.33.4, when an `HTTPProxy` is configured with incompatible combination of both `.spec.virtualhost.tls.enableFallbackCertificate: true` and `.spec.virtualhost.jwtProviders`, Contour does not reject the configuration. Consequently, requests from clients that do not send TLS SNI or send an unrecognized SNI (one that does not match any `HTTPProxy` FQDN) bypass configured JWT verification and are proxied to upstream services without a valid token. This issue is fixed in Contour v1.33.5. Contour now rejects and marks invalid any `HTTPProxy` resources that combine `.spec.virtualhost.tls.enableFallbackCertificate: true` with `.spec.virtualhost.jwtProviders`. Affected resources will receive a status  condition with the error reason `TLSIncompatibleFeatures`. As a workaround, do not enable `.spec.virtualhost.tls.enableFallbackCertificate` on `HTTPProxy` resources that also define `.spec.virtualhost.jwtProviders`. Remove one of the two settings to avoid the invalid configuration.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-50149?

4 open source packages ship an affected version, including github.com/projectcontour/contour and contour.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/projectcontour/contour` | Go | From 1.23.0 | 1.33.5 |
| `github.com/projectcontour/contour` | Go | From 1.23.0 | 1.33.5 |
| `github.com/projectcontour/contour` | Go | From 1.23.0 | 1.33.5 |
| `contour` | Bitnami | From 1.23.0 | 1.33.5 |

## How do I fix CVE-2026-50149?

Upgrade github.com/projectcontour/contour to 1.33.5 or later.

## Is CVE-2026-50149 being exploited?

There is no known exploitation of CVE-2026-50149 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50149 and fix it if it is affected.

What it is: CVE-2026-50149 is a medium-severity authentication bypass vulnerability in projectcontour contour, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50149 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/projectcontour/contour (Go): affected from 1.23.0; fixed in 1.33.5
- github.com/projectcontour/contour (Go): affected from 1.23.0; fixed in 1.33.5
- github.com/projectcontour/contour (Go): affected from 1.23.0; fixed in 1.33.5
- contour (Bitnami): affected from 1.23.0; fixed in 1.33.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50149/ (Markdown: https://insights.sbomify.com/CVE-2026-50149/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50149
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50149
- OSV: https://osv.dev/vulnerability/CVE-2026-50149

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50149/
Summaries are generated and may contain mistakes; the official description above is the record.
