# CVE-2026-50152: Missing authorization in ceph

> Low-privileged Ceph users can read sensitive cluster secrets, including SSH keys, leading to full cluster and host compromise.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2026
- **Updated:** 1 Sep 2026
- **Also known as:** BIT-ceph-2026-50152, DEBIAN-CVE-2026-50152, ECHO-c8d6-5e39-6e63, GHSA-rg9p-5xcp-wm8h, MINI-j88f-4683-57pg, MINI-w7vr-v57v-43j2, UBUNTU-CVE-2026-50152

## What is CVE-2026-50152?

CVE-2026-50152 is a critical missing authorization vulnerability in ceph, published on 27 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Ceph is an open-source distributed storage platform providing object, block, and file storage. In versions prior to 20.2.4 and 19.2.6, the Monitor subscription handler fails to properly authorize access to the configuration-key store, allowing any CephX user with only  `mon allow r` capabilities to read the entire store by sending a single crafted MMonSubscribe message. The config-key store holds sensitive secrets including OSD LUKS disk-encryption passphrases and, on cephadm-managed clusters, the SSH private key that cephadm uses to reach every host in the cluster. Because that key grants root on every node under the default cephadm configuration, a low-privileged read-only account can escalate to full cluster and host compromise. This issue is fixed in versions 20.2.4 and 19.2.6

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-50152?

1 open source package ship an affected version, including ceph.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ceph` | Bitnami | From 19.0.0 | 19.2.6, 20.2.4 |

## How do I fix CVE-2026-50152?

Upgrade ceph to a fixed version for your release line: 19.2.6 or 20.2.4.

## Is CVE-2026-50152 being exploited?

There is no known exploitation of CVE-2026-50152 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50152 and fix it if it is affected.

What it is: CVE-2026-50152 is a critical missing authorization vulnerability in ceph, published on 27 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50152 in the wild and no public exploit code.

Affected packages and fixed versions:
- ceph (Bitnami): affected from 19.0.0; fixed in 19.2.6, 20.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50152/ (Markdown: https://insights.sbomify.com/CVE-2026-50152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50152
- OSV: https://osv.dev/vulnerability/CVE-2026-50152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50152/
Summaries are generated and may contain mistakes; the official description above is the record.
