# CVE-2026-50157: Auth0 Symfony: Bearer Token Accepted via URL Query Parameter in Auth0 Symfony SDK

> The Auth0 Symfony SDK accepts bearer tokens via URL query parameters, risking token exposure in logs and history, allowing potential replay attacks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-ffq7-hh2j-r24p

## What is CVE-2026-50157?

CVE-2026-50157 is a medium-severity vulnerability in auth0 symfony, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Auth0 Symfony is a Symfony SDK for Auth0 Authentication and Management APIs. From 5.0.0-BETA0 until 5.9.0, the Authorizer::authenticate() and Authorizer::supports() paths in the Authorizer security authenticator may accept OAuth 2.0 bearer access tokens from the token URL query parameter as well as the Authorization header for protected HTTP routes. Query-string tokens can be recorded in server logs, browser history, or referrer data and then replayed against protected API endpoints. This issue is fixed in version 5.9.0.

Weakness: CWE-598 (Use of HTTP Request With Sensitive Query String)

## Which versions are affected by CVE-2026-50157?

2 open source packages ship an affected version, including auth0/symfony.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0/symfony` | Packagist | From 5.0.0-BETA0 | 5.9.0 |
| `auth0/symfony` | Packagist | From 5.0.0-BETA0 | 5.9.0 |

## How do I fix CVE-2026-50157?

Upgrade auth0/symfony to 5.9.0 or later.

## Is CVE-2026-50157 being exploited?

There is no known exploitation of CVE-2026-50157 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50157 and fix it if it is affected.

What it is: CVE-2026-50157 is a medium-severity vulnerability in auth0 symfony, published on 14 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50157 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0/symfony (Packagist): affected from 5.0.0-BETA0; fixed in 5.9.0
- auth0/symfony (Packagist): affected from 5.0.0-BETA0; fixed in 5.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50157/ (Markdown: https://insights.sbomify.com/CVE-2026-50157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50157
- OSV: https://osv.dev/vulnerability/CVE-2026-50157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50157/
Summaries are generated and may contain mistakes; the official description above is the record.
