CVE-2026-50159 Mermaid allows CSS injection applying to sibling elements of the diagram
Attackers can inject CSS via diagram text to alter page appearance or behavior, requiring an upgrade to Mermaid.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-50159?
CVE-2026-50159 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 6 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. Prior to 10.9.8 and 11.16.1, Mermaid is vulnerable to CSS injection via sibling combinator selectors generated from diagram-supplied class or id names. An attacker who can supply diagram text can inject arbitrary CSS into the rendered page, potentially altering the appearance or behavior of unrelated page elements. This issue is fixed in versions 10.9.8 and 11.16.1.
Weakness: CWE-94
Which versions are affected by CVE-2026-50159?
4 open source packages ship an affected version, including mermaid.
| Package | Affected | Fixed in |
|---|---|---|
mermaid npm | All versions | 10.9.8 |
mermaid npm | All versions | 10.9.8 |
mermaid npm | From 11.0.0-alpha.1 | 11.16.1 |
mermaid npm | From 11.0.0-alpha.1 | 11.16.1 |
How do I fix CVE-2026-50159?
Upgrade mermaid to a fixed version for your release line: 10.9.8 or 11.16.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-50159 being exploited?
There is no known exploitation of CVE-2026-50159 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-TH91746, DEBIAN-CVE-2026-50159, GHSA-6x64-9x62-f2gx, MINI-3vwg-m673-3jwr, MINI-79x4-8jrf-8w7x, MINI-7xh7-6c8q-cxr9 and 2 more.