# CVE-2026-50166: Kuma: kumactl connects to control plane without verifying TLS certificate when no CA is configured


- **Severity:** Medium 5.5 (`CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 16 Sep 2026

## What is CVE-2026-50166?

CVE-2026-50166 is a medium-severity vulnerability in kumahq kuma, published on 15 Sep 2026. 

### Official description

Kuma is a modern Envoy-based service mesh that can run on every cloud across both Kubernetes and VMs. Prior to 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7, a kumactl profile manually configured for an HTTPS control plane without --ca-cert-file disables TLS peer verification and sends API tokens over the unverified connection. An attacker on the network path can intercept user or administrator API tokens and act against the control plane as the compromised user. The default local profile is unaffected because it uses plain HTTP. This issue is fixed in versions 2.7.26, 2.9.16, 2.11.14, 2.12.11, and 2.13.7.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-50166?


## How do I fix CVE-2026-50166?

Upgrade to a fixed version.

## Is CVE-2026-50166 being exploited?

There is no known exploitation of CVE-2026-50166 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50166 and fix it if it is affected.

What it is: CVE-2026-50166 is a medium-severity vulnerability in kumahq kuma, published on 15 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-50166 in the wild and no public exploit code.

Affected product: kumahq kuma. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50166/ (Markdown: https://insights.sbomify.com/CVE-2026-50166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50166
- OSV: https://osv.dev/vulnerability/CVE-2026-50166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50166/
Summaries are generated and may contain mistakes; the official description above is the record.
