# CVE-2026-50167: Kurrier: Authenticated cross-user authorization bypass in Kurrier API

> Authenticated attackers can read other users' webhook and identity metadata due to missing ownership checks in API endpoints.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-f7h3-f5vh-3764

## What is CVE-2026-50167?

CVE-2026-50167 is a medium-severity missing authorization vulnerability in kurrier-org kurrier, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kurrier is a modern, self-hosted workspace for email, calendar, contacts, and storage. Prior to 1.2.4, Kurrier API endpoints for listing and retrieving webhook and identity resources did not enforce ownership checks for authenticated API requests. An attacker with a valid API key could use another account's identifiers to read and enumerate webhook and identity resources belonging to that account through apps/worker/server/routes/api/kurrier/webhooks/[id].get.ts, apps/worker/server/routes/api/kurrier/webhooks/index.get.ts, apps/worker/server/routes/api/kurrier/identities/[id].get.ts, and apps/worker/server/routes/api/kurrier/identities/index.get.ts. Anonymous requests and invalid API keys were rejected, and cross-user modification operations were blocked, but affected GET and list operations could expose another user's resource metadata. This issue is fixed in version 1.2.4.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-50167?


## How do I fix CVE-2026-50167?

No fix has been published for CVE-2026-50167 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-50167 being exploited?

There is no known exploitation of CVE-2026-50167 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50167 and fix it if it is affected.

What it is: CVE-2026-50167 is a medium-severity missing authorization vulnerability in kurrier-org kurrier, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50167 in the wild and no public exploit code.

Affected product: kurrier-org kurrier. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50167/ (Markdown: https://insights.sbomify.com/CVE-2026-50167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50167
- OSV: https://osv.dev/vulnerability/CVE-2026-50167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50167/
Summaries are generated and may contain mistakes; the official description above is the record.
