CVE-2026-50169 Angular Service Worker Policy-Bypass & Credential-Stripping Vulnerabilities

Medium 5.7 Published Updated

Angular service worker bypasses strict redirect policies, potentially exposing cookies or sensitive data via unintended redirects.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-50169?

CVE-2026-50169 is a medium-severity vulnerability in angular, published on 22 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips the strict, client-defined request redirect policy configuration (such as redirect: 'error'), falling back to the browser's default 'follow' strategy. If the target web application makes client-side requests with a strict policy (e.g., expecting a network error instead of automatically following redirects), the service worker will bypass this instruction and automatically follow HTTP 3xx redirects to other destinations. This acts as an unintended proxy/intermediary ("Confused Deputy") and can result in cookie/credential exposure or same-origin session-restricted data leakage if public dynamic routes redirect to sensitive routes. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Weakness: CWE-524, CWE-441, CWE-200

Which versions are affected by CVE-2026-50169?

10 open source packages ship an affected version, including @angular/service-worker. It affects 1 product.

PackageAffectedFixed in
@angular/service-worker npmAll versions to 18.2.14None
@angular/service-worker npmAll versions to 18.2.14None
@angular/service-worker npmFrom 19.0.0-next.019.2.23
@angular/service-worker npmFrom 19.0.0-next.019.2.23
@angular/service-worker npmFrom 20.0.0-next.020.3.22
@angular/service-worker npmFrom 20.0.0-next.020.3.22
4 more packages
@angular/service-worker npmFrom 21.0.0-next.021.2.15
@angular/service-worker npmFrom 21.0.0-next.021.2.15
@angular/service-worker npmFrom 22.0.0-next.022.0.0-rc.2
@angular/service-worker npmFrom 22.0.0-next.022.0.0-rc.2

Products include Angular Angular.

How do I fix CVE-2026-50169?

Upgrade @angular/service-worker to a fixed version for your release line: 19.2.23, 20.3.22, 21.2.15 or 22.0.0-rc.2.

Is CVE-2026-50169 being exploited?

There is no known exploitation of CVE-2026-50169 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-50169, GHSA-gv2q-mqqv-365m, UBUNTU-CVE-2026-50169.

Is CVE-2026-50169 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free