# CVE-2026-50169: Angular Service Worker Policy-Bypass & Credential-Stripping Vulnerabilities

> Angular service worker bypasses strict redirect policies, potentially exposing cookies or sensitive data via unintended redirects.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-50169, GHSA-gv2q-mqqv-365m, UBUNTU-CVE-2026-50169

## What is CVE-2026-50169?

CVE-2026-50169 is a medium-severity vulnerability in angular, published on 22 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips the strict, client-defined request redirect policy configuration (such as redirect: 'error'), falling back to the browser's default 'follow' strategy. If the target web application makes client-side requests with a strict policy (e.g., expecting a network error instead of automatically following redirects), the service worker will bypass this instruction and automatically follow HTTP 3xx redirects to other destinations. This acts as an unintended proxy/intermediary ("Confused Deputy") and can result in cookie/credential exposure or same-origin session-restricted data leakage if public dynamic routes redirect to sensitive routes. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information), CWE-441 (Unintended Proxy or Intermediary), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-50169?

10 open source packages ship an affected version, including @angular/service-worker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/service-worker` | npm | All versions to 18.2.14 | None |
| `@angular/service-worker` | npm | All versions to 18.2.14 | None |
| `@angular/service-worker` | npm | From 19.0.0-next.0 | 19.2.23 |
| `@angular/service-worker` | npm | From 19.0.0-next.0 | 19.2.23 |
| `@angular/service-worker` | npm | From 20.0.0-next.0 | 20.3.22 |
| `@angular/service-worker` | npm | From 20.0.0-next.0 | 20.3.22 |
| `@angular/service-worker` | npm | From 21.0.0-next.0 | 21.2.15 |
| `@angular/service-worker` | npm | From 21.0.0-next.0 | 21.2.15 |
| `@angular/service-worker` | npm | From 22.0.0-next.0 | 22.0.0-rc.2 |
| `@angular/service-worker` | npm | From 22.0.0-next.0 | 22.0.0-rc.2 |

Products: Angular Angular.

## How do I fix CVE-2026-50169?

Upgrade @angular/service-worker to a fixed version for your release line: 19.2.23, 20.3.22, 21.2.15 or 22.0.0-rc.2.

## Is CVE-2026-50169 being exploited?

There is no known exploitation of CVE-2026-50169 in the wild and no public exploit code.

## Other vulnerabilities in angular

- [CVE-2026-68945](https://insights.sbomify.com/CVE-2026-68945/): Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning (high 8.8)
- [CVE-2026-46417](https://insights.sbomify.com/CVE-2026-46417/): Angular: SSRF via Hostname Hijacking in @angular/platform-server (high 8.8)
- [CVE-2026-50168](https://insights.sbomify.com/CVE-2026-50168/): Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass (high 8.8)
- [CVE-2026-54266](https://insights.sbomify.com/CVE-2026-54266/): Angular: Weak 32-Bit Cache Key Hashing in `HttpTransferCache` Leading to Cross-Request Data Leakage and State Poisoning (high 8.8)
- [CVE-2026-41423](https://insights.sbomify.com/CVE-2026-41423/): Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50169 and fix it if it is affected.

What it is: CVE-2026-50169 is a medium-severity vulnerability in angular, published on 22 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-50169 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/service-worker (npm): affected all versions up to 18.2.14; no fix listed
- @angular/service-worker (npm): affected all versions up to 18.2.14; no fix listed
- @angular/service-worker (npm): affected from 19.0.0-next.0; fixed in 19.2.23
- @angular/service-worker (npm): affected from 19.0.0-next.0; fixed in 19.2.23
- @angular/service-worker (npm): affected from 20.0.0-next.0; fixed in 20.3.22
- @angular/service-worker (npm): affected from 20.0.0-next.0; fixed in 20.3.22
- @angular/service-worker (npm): affected from 21.0.0-next.0; fixed in 21.2.15
- @angular/service-worker (npm): affected from 21.0.0-next.0; fixed in 21.2.15
- @angular/service-worker (npm): affected from 22.0.0-next.0; fixed in 22.0.0-rc.2
- @angular/service-worker (npm): affected from 22.0.0-next.0; fixed in 22.0.0-rc.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50169/ (Markdown: https://insights.sbomify.com/CVE-2026-50169/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50169
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50169
- OSV: https://osv.dev/vulnerability/CVE-2026-50169

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50169/
Summaries are generated and may contain mistakes; the official description above is the record.
