CVE-2026-50170 Angular: Information Leak via Default Caching of Credentialed Requests in HttpTransferCache

High 8.2 Published Updated

Attackers can leak private user data via cached SSR pages when Angular's HttpTransferCache fails to exclude credentialed requests.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-50170?

CVE-2026-50170 is a high-severity vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, a vulnerability was discovered in @angular/common when Server-Side Rendering (SSR) and hydration are enabled. The HttpTransferCache utility optimizes hydration by caching outgoing HTTP requests performed during SSR and transferring the cached state to the client-side application via TransferState. However, the caching mechanism fails to inspect the withCredentials flag or the Cookie header of outgoing requests. As a result, credentialed, user-specific responses may be cached by default in the shared TransferState payload. When these responses are serialized into the HTML, any caching layer (such as a CDN, reverse proxy, or shared server cache) that caches the SSR-rendered HTML page could inadvertently cache and leak one user's private data to other users, leading to a high-severity information disclosure vulnerability. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Weakness: CWE-524

Which versions are affected by CVE-2026-50170?

10 open source packages ship an affected version, including @angular/common. It affects 1 product.

PackageAffectedFixed in
@angular/common npmAll versions to 18.2.14None
@angular/common npmAll versions to 18.2.14None
@angular/common npmFrom 19.0.0-next.019.2.23
@angular/common npmFrom 19.0.0-next.019.2.23
@angular/common npmFrom 20.0.0-next.020.3.22
@angular/common npmFrom 20.0.0-next.020.3.22
4 more packages
@angular/common npmFrom 21.0.0-next.021.2.15
@angular/common npmFrom 21.0.0-next.021.2.15
@angular/common npmFrom 22.0.0-next.022.0.0-rc.2
@angular/common npmFrom 22.0.0-next.022.0.0-rc.2

Products include Angular Angular.

How do I fix CVE-2026-50170?

Upgrade @angular/common to a fixed version for your release line: 19.2.23, 20.3.22, 21.2.15 or 22.0.0-rc.2.

Is CVE-2026-50170 being exploited?

There is no known exploitation of CVE-2026-50170 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-50170, GHSA-q6f4-qqrg-jv6x, UBUNTU-CVE-2026-50170.

Is CVE-2026-50170 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free