CVE-2026-50171 Angular: Denial of Service (DoS) via OOM in Number Formatting (digitsInfo)

High 8.2 Published Updated

Attackers can cause a Denial of Service via Out-of-Memory errors in Angular's number formatting functions by providing maliciously crafted digit information parameters.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-50171?

CVE-2026-50171 is a high-severity denial of service vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, a Denial of Service (DoS) vulnerability exists in the @angular/common package of Angular. The formatNumber function, which is also utilized by DecimalPipe, PercentPipe, and CurrencyPipe, does not properly validate the upper bounds of the digitsInfo parameter. Specifically, the minimum and maximum fraction digits parsed from the digitsInfo string (e.g., 1.2-4) are converted to integers and used without limits. When parsing a maliciously crafted digitsInfo string with excessively large fraction digit values (e.g., 1.200000000-200000000), the internal roundNumber function attempts to pad the digits array to match the requested fraction size. This results in an unbounded loop that repeatedly pushes elements into an array. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Weakness: CWE-834, CWE-400

Which versions are affected by CVE-2026-50171?

10 open source packages ship an affected version, including @angular/common. It affects 1 product.

PackageAffectedFixed in
@angular/common npmAll versions to 18.2.14None
@angular/common npmAll versions to 18.2.14None
@angular/common npmFrom 19.0.0-next.019.2.23
@angular/common npmFrom 19.0.0-next.019.2.23
@angular/common npmFrom 20.0.0-next.020.3.22
@angular/common npmFrom 20.0.0-next.020.3.22
4 more packages
@angular/common npmFrom 21.0.0-next.021.2.15
@angular/common npmFrom 21.0.0-next.021.2.15
@angular/common npmFrom 22.0.0-next.022.0.0-rc.2
@angular/common npmFrom 22.0.0-next.022.0.0-rc.2

Products include Angular Angular.

How do I fix CVE-2026-50171?

Upgrade @angular/common to a fixed version for your release line: 19.2.23, 20.3.22, 21.2.15 or 22.0.0-rc.2.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-50171 being exploited?

There is no known exploitation of CVE-2026-50171 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-50171, GHSA-p3vc-36g9-x9gr, UBUNTU-CVE-2026-50171.

Is CVE-2026-50171 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free