CVE-2026-50184 Angular: Request Credential & Cache Policy Stripping in Angular Service Worker

Medium 5.7 Published Updated

Angular Service Worker strips credential and cache policies, causing session leaks and caching of private data, requiring an upgrade to secure client-side request handling.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-50184?

CVE-2026-50184 is a medium-severity vulnerability in angular, published on 22 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23, an issue in the @angular/service-worker package compromises the integrity of request-policy enforcement during request reconstruction. When the Angular Service Worker intercepts network requests for matched assets, it reconstructs a new Request object using an internal helper function. During this reconstruction process, the helper function strips explicit client-defined safety parameters: the credentials configuration (such as credentials: 'omit') and the HTTP cache mode configuration (such as cache: 'no-store'). These are reverted back to standard browser-default parameters (credentials: 'same-origin' and default HTTP cache properties). This causes the browser to include active credentials (such as cookies or Authorization headers) on outbound requests where the client-side developer explicitly instructed they should be omitted, leading to potential session leaks. Additionally, it causes private or non-cacheable resources to be cached by the service worker's engine, making private page states accessible or persistent inside the client's local cache post-logout. This vulnerability is fixed in 22.0.0-rc.2, 21.2.15, 20.3.22, and 19.2.23.

Weakness: CWE-524, CWE-200

Which versions are affected by CVE-2026-50184?

10 open source packages ship an affected version, including @angular/service-worker. It affects 1 product.

PackageAffectedFixed in
@angular/service-worker npmAll versions to 18.2.14None
@angular/service-worker npmAll versions to 18.2.14None
@angular/service-worker npmFrom 19.0.0-next.019.2.23
@angular/service-worker npmFrom 19.0.0-next.019.2.23
@angular/service-worker npmFrom 20.0.0-next.020.3.22
@angular/service-worker npmFrom 20.0.0-next.020.3.22
4 more packages
@angular/service-worker npmFrom 21.0.0-next.021.2.15
@angular/service-worker npmFrom 21.0.0-next.021.2.15
@angular/service-worker npmFrom 22.0.0-next.022.0.0-rc.2
@angular/service-worker npmFrom 22.0.0-next.022.0.0-rc.2

Products include Angular Angular.

How do I fix CVE-2026-50184?

Upgrade @angular/service-worker to a fixed version for your release line: 19.2.23, 20.3.22, 21.2.15 or 22.0.0-rc.2.

Is CVE-2026-50184 being exploited?

There is no known exploitation of CVE-2026-50184 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-50184, GHSA-95qp-cmmw-mgqv, UBUNTU-CVE-2026-50184.

Is CVE-2026-50184 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free