CVE-2026-50188 Kirby: Request header injection in `Http\Remote`
Attackers can inject unintended HTTP headers via newline characters in untrusted data, potentially manipulating remote requests in Kirby CMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-50188?
CVE-2026-50188 is a medium-severity vulnerability in getkirby kirby, published on 9 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Kirby is an open-source content management system. Prior to 4.9.4 and 5.4.4, Kirby sites and plugins using the Kirby Http Remote class, including Remote::request(), Remote::get(), and Remote::post(), to send outgoing HTTP requests with untrusted data in the headers option could allow newline characters in a header value to inject a separate unintended request header to the remote service. This issue is fixed in versions 4.9.4 and 5.4.4.
Which versions are affected by CVE-2026-50188?
4 open source packages ship an affected version, including getkirby/cms.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 4.9.4 |
getkirby/cms Packagist | All versions | 4.9.4 |
getkirby/cms Packagist | From 5.0.0-alpha.1 | 5.4.4 |
getkirby/cms Packagist | From 5.0.0-alpha.1 | 5.4.4 |
How do I fix CVE-2026-50188?
Upgrade getkirby/cms to a fixed version for your release line: 4.9.4 or 5.4.4.
Is CVE-2026-50188 being exploited?
There is no known exploitation of CVE-2026-50188 in the wild and no public exploit code.
Sources
Also known as GHSA-4v4h-m2qq-ppgw.