# CVE-2026-50221: OpenStack Swift vulnerable to authenticated server-side request forgery

> Authenticated users can inject headers to trigger SSRF, exposing internal cluster metadata and encryption details in OpenStack Swift.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-50221, GHSA-h8rc-w822-q8vq, PYSEC-2026-4173, UBUNTU-CVE-2026-50221

## What is CVE-2026-50221?

CVE-2026-50221 is a medium-severity server-side request forgery vulnerability in OpenStack Swift, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In OpenStack Swift before 2.37.2, proxy-server does not strip internal update headers (X-Container-Host, X-Container-Device, X-Delete-At-Host, X-Delete-At-Device) from client requests before forwarding them to object-servers. An authenticated user with write access can inject these headers to redirect container update requests to an attacker-controlled server, enabling server-side request forgery. The SSRF requests expose internal cluster metadata including storage policy indexes, partition mappings, device names, and when at rest encryption is enabled, cipher text and initialization vectors for the container-level encryption key. The attacker can also cause "ghost listings" in arbitrary containers via the shard-range redirect mechanism.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-50221?

3 open source packages ship an affected version, including swift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `swift` | PyPI | All versions | 2.37.2 |
| `swift` | PyPI | All versions | 2.37.2 |
| `swift` | PyPI | All versions | 2.37.2 |

Products: Openstack Swift.

## How do I fix CVE-2026-50221?

Upgrade swift to 2.37.2 or later.

## Is CVE-2026-50221 being exploited?

There is no known exploitation of CVE-2026-50221 in the wild and no public exploit code.

## Other vulnerabilities in OpenStack Swift

- [CVE-2016-0737](https://insights.sbomify.com/CVE-2016-0737/): OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service (high 7.5)
- [CVE-2016-0738](https://insights.sbomify.com/CVE-2016-0738/): OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service (high 7.5)
- [CVE-2026-49017](https://insights.sbomify.com/CVE-2026-49017/): OpenStack Swift: s3api middleware enters an infinite loop when processing a truncated aws-chunked PUT request body (high 7.1)
- [CVE-2013-6396](https://insights.sbomify.com/CVE-2013-6396/): Python Swift client is vulnerable to Missing SSL Certificate Check (medium 5.8)
- [CVE-2015-5223](https://insights.sbomify.com/CVE-2015-5223/): OpenStack Object Storage (Swift) Sensitive Data Exposure (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50221 and fix it if it is affected.

What it is: CVE-2026-50221 is a medium-severity server-side request forgery vulnerability in OpenStack Swift, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50221 in the wild and no public exploit code.

Affected packages and fixed versions:
- swift (PyPI): affected all versions; fixed in 2.37.2
- swift (PyPI): affected all versions; fixed in 2.37.2
- swift (PyPI): affected all versions; fixed in 2.37.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50221/ (Markdown: https://insights.sbomify.com/CVE-2026-50221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50221
- OSV: https://osv.dev/vulnerability/CVE-2026-50221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50221/
Summaries are generated and may contain mistakes; the official description above is the record.
