CVE-2026-50223 Apache OFBiz: DataResource Low-Privileged Authenticated FreeMarker Template Injection Leads to Remote Code Execution
Low-privileged authenticated users can inject FreeMarker templates in DataResource to achieve remote code execution in Apache OFBiz.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-50223?
CVE-2026-50223 is a high-severity code injection vulnerability in Apache Ofbiz, published on 10 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache OFBiz allows a low-privileged authenticated user with Content/DataResource editing privileges to perform template injection attacks that could lead to Remote Code Execution.
This issue affects Apache OFBiz: before 24.09.07.
Users are recommended to upgrade to version 24.09.07, which fixes the issue.
Weakness: CWE-94
Which versions are affected by CVE-2026-50223?
It affects 1 product.
Products include Apache Ofbiz.
How do I fix CVE-2026-50223?
No fix has been published for CVE-2026-50223 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-50223 being exploited?
There is no known exploitation of CVE-2026-50223 in the wild and no public exploit code.
Other vulnerabilities in Apache Ofbiz
- CVE-2024-45195 Apache OFBiz Forced Browsing
- CVE-2024-32113 Apache OFBiz Path Traversal
- CVE-2024-38856 Apache OFBiz Incorrect Authorization
- CVE-2013-2250 Code injection in n/a
- CVE-2012-3506 Unspecified vulnerability in the Apache Open For Business Project (aka OFBiz) 10.04.x before 10.04.03 has unknown impact and attack vectors.
Sources
Also known as GHSA-862q-5rrg-cc9p.