# CVE-2026-50272: dd-trace: Improper parsing of W3C baggage headers may lead to DoS


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** CLEANSTART-2026-GR75196, GHSA-wxqq-gcq8-c443, MINI-wq4h-c6wq-jjv9, ROOT-APP-NPM-CVE-2026-50272

## What is CVE-2026-50272?

CVE-2026-50272 is a high-severity vulnerability in DataDog dd-trace-js, published on 17 Jul 2026. 

### Official description

dd-trace is the Datadog APM client for Node.js. Prior to 5.100.0, W3C baggage propagation in packages/dd-trace/src/baggage.js and packages/dd-trace/src/opentracing/propagation/text_map.js parsed incoming baggage HTTP headers without enforcing DD_TRACE_BAGGAGE_MAX_ITEMS or DD_TRACE_BAGGAGE_MAX_BYTES on extraction. A remote, unauthenticated attacker can send a request whose baggage header contains an arbitrarily large number of comma-separated key-value pairs, or a single very large value, causing unbounded CPU and memory consumption and enabling a remote denial of service against any HTTP service with baggage propagation enabled. This issue is fixed in version 5.100.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-50272?

2 open source packages ship an affected version, including dd-trace.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dd-trace` | npm | All versions | 5.100.0 |
| `dd-trace` | npm | All versions | 5.100.0 |

## How do I fix CVE-2026-50272?

Upgrade dd-trace to 5.100.0 or later.

## Is CVE-2026-50272 being exploited?

There is no known exploitation of CVE-2026-50272 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50272 and fix it if it is affected.

What it is: CVE-2026-50272 is a high-severity vulnerability in DataDog dd-trace-js, published on 17 Jul 2026. 
Exploitation: There is no known exploitation of CVE-2026-50272 in the wild and no public exploit code.

Affected packages and fixed versions:
- dd-trace (npm): affected all versions; fixed in 5.100.0
- dd-trace (npm): affected all versions; fixed in 5.100.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50272/ (Markdown: https://insights.sbomify.com/CVE-2026-50272/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50272
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50272
- OSV: https://osv.dev/vulnerability/CVE-2026-50272

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50272/
Summaries are generated and may contain mistakes; the official description above is the record.
