# CVE-2026-50274: dd-trace-go: Improper parsing of W3C baggage headers may lead to DoS

> A remote attacker can cause denial of service in applications using dd-trace-go by sending oversized W3C baggage headers that bypass resource limits.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** CLEANSTART-2026-ES07258, CLEANSTART-2026-TC25973, GHSA-74j5-xf3v-crq8, GO-2026-6000, MINI-2m2c-2v8f-3mwj, MINI-2p7r-r786-r3x8, MINI-3hmv-42qh-7mc2, MINI-3xg2-mgmh-c49v, MINI-4c8v-rhj8-fx89, MINI-4grc-m6q6-pc7j, MINI-5453-wjxf-jqvp, MINI-5mx6-97v7-cg4g, MINI-5w53-pp4f-8jcr, MINI-6hgp-cwp2-3fmq, MINI-6m85-8fr5-27h3, MINI-6mww-xcr7-fmj6, MINI-7868-7fpc-rvqf, MINI-7mrj-mg6c-gw5x, MINI-86q5-p4r8-j79x, MINI-8qg6-hhq6-9fp9, MINI-98j5-r8px-3xc7, MINI-9h7p-5xg8-cpf8, MINI-c9mm-3rqp-pxcg, MINI-cc7p-xc4r-g35c, MINI-cjhh-57p4-4fqp, MINI-gcvx-wx8x-xqv2, MINI-gmxx-pg39-4864, MINI-hprp-m653-qvq7, MINI-hqq2-jfmr-qhpw, MINI-hv96-p6v8-w4qc, MINI-hvp6-wp5j-37h4, MINI-j5j8-mmwv-f98q, MINI-j5vg-5p57-h6jx, MINI-j734-56v6-jpqr, MINI-p5c6-mrq7-mhc6, MINI-p8xj-76f8-c6gj, MINI-pgf6-573g-47f5, MINI-pvm7-9427-5q4v, MINI-pw4v-6qv7-fwq5, MINI-rvv2-m5gg-wxx7, MINI-vqwv-65vf-3m8p, MINI-vvjg-hj75-mh99, MINI-wx9v-qr3f-9gq3, MINI-x5mj-2w86-9wh9, MINI-xm84-cjw8-q2v8, MINI-xx7c-3c9c-4fh4

## What is CVE-2026-50274?

CVE-2026-50274 is a high-severity denial of service vulnerability in DataDog dd-trace-go, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Datadog dd-trace-go is a Go client library for Datadog application performance monitoring, profiling, and security monitoring. Prior to 2.8.1, Datadog tracing libraries that implement W3C baggage propagation parse incoming baggage HTTP headers without enforcing DD_TRACE_BAGGAGE_MAX_ITEMS or DD_TRACE_BAGGAGE_MAX_BYTES limits on the extract path. A remote, unauthenticated attacker can send a request whose baggage header contains an arbitrarily large number of comma-separated key-value pairs or a single very large value, causing unbounded CPU and memory consumption and enabling a remote denial of service against HTTP services with baggage propagation enabled. This issue is fixed in version 2.8.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-50274?

6 open source packages ship an affected version, including github.com/DataDog/dd-trace-go and github.com/DataDog/dd-trace-go/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/DataDog/dd-trace-go` | Go | All versions | None |
| `github.com/DataDog/dd-trace-go` | Go | All versions to 1.24.1 | None |
| `github.com/DataDog/dd-trace-go` | Go | All versions to 1.24.1 | None |
| `github.com/DataDog/dd-trace-go/v2` | Go | All versions | 2.8.1 |
| `github.com/DataDog/dd-trace-go/v2` | Go | All versions | 2.8.1 |
| `github.com/DataDog/dd-trace-go/v2` | Go | All versions | 2.8.1 |

## How do I fix CVE-2026-50274?

Upgrade to a fixed version.

## Is CVE-2026-50274 being exploited?

There is no known exploitation of CVE-2026-50274 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50274 and fix it if it is affected.

What it is: CVE-2026-50274 is a high-severity denial of service vulnerability in DataDog dd-trace-go, published on 17 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50274 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/DataDog/dd-trace-go (Go): affected all versions; no fix listed
- github.com/DataDog/dd-trace-go (Go): affected all versions up to 1.24.1; no fix listed
- github.com/DataDog/dd-trace-go (Go): affected all versions up to 1.24.1; no fix listed
- github.com/DataDog/dd-trace-go/v2 (Go): affected all versions; fixed in 2.8.1
- github.com/DataDog/dd-trace-go/v2 (Go): affected all versions; fixed in 2.8.1
- github.com/DataDog/dd-trace-go/v2 (Go): affected all versions; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50274/ (Markdown: https://insights.sbomify.com/CVE-2026-50274/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50274
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50274
- OSV: https://osv.dev/vulnerability/CVE-2026-50274

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50274/
Summaries are generated and may contain mistakes; the official description above is the record.
