# CVE-2026-50275: Datadog PHP Tracer: Improper parsing of W3C baggage headers may lead to DoS

> Remote attackers can cause denial of service by sending oversized W3C baggage headers to applications using the Datadog PHP Tracer.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-phwx-ww2p-cv9v

## What is CVE-2026-50275?

CVE-2026-50275 is a high-severity denial of service vulnerability in DataDog dd-trace-php, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Datadog PHP Tracer provides application performance monitoring and distributed tracing for PHP. Prior to 1.19.2, ddtrace_deserialize_baggage in ext/distributed_tracing_headers.c parses incoming W3C baggage HTTP headers without enforcing DD_TRACE_BAGGAGE_MAX_ITEMS or DD_TRACE_BAGGAGE_MAX_BYTES. A remote unauthenticated client can send an arbitrarily large number of comma-separated key-value pairs or a single oversized value, causing the tracer to allocate hash-map entries and consume unbounded CPU and memory on each request. Baggage extraction is enabled by default in most affected deployments unless baggage is removed from DD_TRACE_PROPAGATION_STYLE or DD_TRACE_PROPAGATION_STYLE_EXTRACT. This issue is fixed in version 1.19.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-50275?


## How do I fix CVE-2026-50275?

No fix has been published for CVE-2026-50275 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-50275 being exploited?

There is no known exploitation of CVE-2026-50275 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50275 and fix it if it is affected.

What it is: CVE-2026-50275 is a high-severity denial of service vulnerability in DataDog dd-trace-php, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50275 in the wild and no public exploit code.

Affected product: DataDog dd-trace-php. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50275/ (Markdown: https://insights.sbomify.com/CVE-2026-50275/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50275
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50275
- OSV: https://osv.dev/vulnerability/CVE-2026-50275

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50275/
Summaries are generated and may contain mistakes; the official description above is the record.
