# CVE-2026-50277: dd-trace-cpp: Improper parsing of W3C baggage headers may lead to DoS

> Remote attackers can cause denial of service in services using dd-trace-cpp by sending oversized W3C baggage headers, leading to resource exhaustion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-ch7h-phmx-rqwq

## What is CVE-2026-50277?

CVE-2026-50277 is a high-severity denial of service vulnerability in DataDog dd-trace-cpp, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

dd-trace-cpp is the Datadog distributed tracing library for C++. Prior to 2.1.0, dd-trace-cpp parses incoming W3C baggage headers without enforcing DD_TRACE_BAGGAGE_MAX_ITEMS or DD_TRACE_BAGGAGE_MAX_BYTES on the extraction path, even though those limits are enforced during injection. A remote unauthenticated attacker can send a header containing many comma-separated key-value pairs or one very large value, causing per-request hash-map allocation and unbounded CPU and memory consumption. Baggage extraction is enabled by default in most affected tracers unless baggage is removed from DD_TRACE_PROPAGATION_STYLE or DD_TRACE_PROPAGATION_STYLE_EXTRACT, so affected internet-facing services can be denied service. This issue is fixed in version 2.1.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-50277?


## How do I fix CVE-2026-50277?

No fix has been published for CVE-2026-50277 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-50277 being exploited?

There is no known exploitation of CVE-2026-50277 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50277 and fix it if it is affected.

What it is: CVE-2026-50277 is a high-severity denial of service vulnerability in DataDog dd-trace-cpp, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50277 in the wild and no public exploit code.

Affected product: DataDog dd-trace-cpp. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50277/ (Markdown: https://insights.sbomify.com/CVE-2026-50277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50277
- OSV: https://osv.dev/vulnerability/CVE-2026-50277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50277/
Summaries are generated and may contain mistakes; the official description above is the record.
