# CVE-2026-50284: Craft CMS: Missing peer-permission check in `AssetsController::actionDeleteFolder` allows deletion of other users' assets

> Low-privilege users with folder management rights can delete other users' assets due to a missing peer-permission check in the folder deletion endpoint.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 2 Jul 2026
- **Also known as:** GHSA-7h62-6v23-v8fm

## What is CVE-2026-50284?

CVE-2026-50284 is a high-severity missing authorization vulnerability in craftcms cms, published on 1 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft CMS is a content management system (CMS). In versions 5.0.0-RC1 through 5.9.21 and 4.0.0-RC1 through 4.17.14, theAssetsController::actionDeleteFolder() only requires the deleteAssets:<volume-uid> permission for the target folder. It never enforces deletePeerAssets:<volume-uid>, even though Assets::deleteFoldersByIds() cascades deletion to every descendant folder and every asset inside, regardless of the uploader's assigned privileges. A low-privilege user who has been granted folder-management rights on a shared volume can therefore destroy assets uploaded by other users (peer assets), bypassing the per-asset peer-permission check that the sibling actionDeleteAsset endpoint correctly applies. This issue has been fixed in versions 4.17.15 and 5.9.22.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-50284?

4 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.15 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.17.15 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.22 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.9.22 |

## How do I fix CVE-2026-50284?

Upgrade craftcms/cms to a fixed version for your release line: 4.17.15 or 5.9.22.

## Is CVE-2026-50284 being exploited?

There is no known exploitation of CVE-2026-50284 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50284 and fix it if it is affected.

What it is: CVE-2026-50284 is a high-severity missing authorization vulnerability in craftcms cms, published on 1 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50284 in the wild and no public exploit code.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.15
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.17.15
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.22
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.9.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50284/ (Markdown: https://insights.sbomify.com/CVE-2026-50284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50284
- OSV: https://osv.dev/vulnerability/CVE-2026-50284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50284/
Summaries are generated and may contain mistakes; the official description above is the record.
