# CVE-2026-50288: @asymmetric-effort/specifyjs: URL parse failure silently allows request

> Attackers can bypass HTTPS validation in SpecifyJS by triggering URL parse errors, allowing insecure requests to proceed.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-8882-frvv-92w4

## What is CVE-2026-50288?

CVE-2026-50288 is a high-severity server-side request forgery vulnerability in asymmetric-effort specifyjs, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SpecifyJS is a declarative TypeScript user interface framework. Prior to version 0.2.136, when `new URL()` throws a parse error, the `assertSecureUrl` function returned without throwing, silently allowing the request to proceed without HTTPS validation. Starting in version 0.2.136, the catch block now throws an error instead of silently returning.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-50288?

2 open source packages ship an affected version, including @asymmetric-effort/specifyjs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@asymmetric-effort/specifyjs` | npm | All versions | 0.2.136 |
| `@asymmetric-effort/specifyjs` | npm | All versions | 0.2.136 |

## How do I fix CVE-2026-50288?

Upgrade @asymmetric-effort/specifyjs to 0.2.136 or later.

## Is CVE-2026-50288 being exploited?

There is no known exploitation of CVE-2026-50288 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50288 and fix it if it is affected.

What it is: CVE-2026-50288 is a high-severity server-side request forgery vulnerability in asymmetric-effort specifyjs, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50288 in the wild and no public exploit code.

Affected packages and fixed versions:
- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136
- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50288/ (Markdown: https://insights.sbomify.com/CVE-2026-50288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50288
- OSV: https://osv.dev/vulnerability/CVE-2026-50288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50288/
Summaries are generated and may contain mistakes; the official description above is the record.
