# CVE-2026-50289: systeminformation: OS command injection in networkInterfaces() via interfaces(5) source-directive path on Linux

> Attackers can execute arbitrary OS commands via shell metacharacters in network interface configuration files when using the systeminformation library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-50289, ECHO-5e42-19f8-7f9b, GHSA-5xpp-75jx-m839, MINI-4g6g-mp3c-wp4q, MINI-c344-5wwm-82pf, MINI-g3w4-pprf-mwrq, MINI-hhjf-h622-h8ch, MINI-hppc-fvhx-4crp, MINI-jgwq-q96w-p3fg, MINI-jh73-gh7c-45ww, MINI-jq4q-fj22-fr77, MINI-qhw7-4mv7-6pm7, MINI-qv39-2r4r-v27w, MINI-rxf9-8qqm-85g2, MINI-vfmj-v9g5-fhpv, ROOT-APP-NPM-CVE-2026-50289, UBUNTU-CVE-2026-50289

## What is CVE-2026-50289?

CVE-2026-50289 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

systeminformation is a System and OS information library for node.js. Prior to 5.31.7, networkInterfaces() on Linux is vulnerable to OS command injection through the Debian/Ubuntu interfaces(5) source directive because lib/network.js checkLinuxDCHPInterfaces() reads /etc/network/interfaces, extracts a source <path> token from file content, and interpolates it unquoted into cat ${file} 2> /dev/null | grep 'iface\|source' executed by execSync(cmd, util.execOptsLinux), allowing a path containing shell metacharacters to execute commands in any process that calls networkInterfaces(), including via getStaticData() and getAllData(). This issue is fixed in version 5.31.7.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-50289?

2 open source packages ship an affected version, including systeminformation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `systeminformation` | npm | All versions | 5.31.7 |
| `systeminformation` | npm | All versions | 5.31.7 |

Products: Systeminformation Systeminformation.

## How do I fix CVE-2026-50289?

Upgrade systeminformation to 5.31.7 or later.

## Is CVE-2026-50289 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50289 exists.

## Other vulnerabilities in sebhildebrandt systeminformation

- [CVE-2023-42810](https://insights.sbomify.com/CVE-2023-42810/): systeminformation SSID Command Injection Vulnerability (critical 9.8)
- [CVE-2021-21388](https://insights.sbomify.com/CVE-2021-21388/): Command Injection Vulnerability in systeminformation (high 8.9)
- [CVE-2026-26318](https://insights.sbomify.com/CVE-2026-26318/): systeminformation has Command Injection via Unsanitized `locate` Output in `versions()` (high 8.8)
- [CVE-2020-7752](https://insights.sbomify.com/CVE-2020-7752/): Command Injection (high 8.8)
- [CVE-2026-26280](https://insights.sbomify.com/CVE-2026-26280/): Systeminformation has a Command Injection via unsanitized interface parameter in wifi.js retry path (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50289 and fix it if it is affected.

What it is: CVE-2026-50289 is a high-severity command injection vulnerability in sebhildebrandt systeminformation, published on 17 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50289 exists.

Affected packages and fixed versions:
- systeminformation (npm): affected all versions; fixed in 5.31.7
- systeminformation (npm): affected all versions; fixed in 5.31.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50289/ (Markdown: https://insights.sbomify.com/CVE-2026-50289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50289
- OSV: https://osv.dev/vulnerability/CVE-2026-50289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50289/
Summaries are generated and may contain mistakes; the official description above is the record.
