{"answers":{"affected":"2 open source packages ship an affected version, including @asymmetric-effort/specifyjs.","exploited":"There is no known exploitation of CVE-2026-50290 in the wild and no public exploit code.","fix":"Upgrade @asymmetric-effort/specifyjs to 0.2.136 or later.","what":"CVE-2026-50290 is a medium-severity cross-site scripting vulnerability in asymmetric-effort specifyjs, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-50290 and fix it if it is affected.\n\nWhat it is: CVE-2026-50290 is a medium-severity cross-site scripting vulnerability in asymmetric-effort specifyjs, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-50290 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136\n- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-50290/ (Markdown: https://insights.sbomify.com/CVE-2026-50290/index.md)","id":"CVE-2026-50290","markdown":"https://insights.sbomify.com/CVE-2026-50290/index.md","name":"CVE-2026-50290","record":{"aliases":["GHSA-93q6-wwjh-jc6h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"TypeScript UI framework","requires_auth":"none","summary":"Attacker can bypass CSS sanitization to inject malicious scripts in legacy browsers, requiring an upgrade to the SpecifyJS library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"SpecifyJS is a declarative TypeScript user interface framework. Prior to version 0.2.136, CSS value sanitization stripped `expression(` and `url(javascript:` using simple regex, but could be bypassed with CSS unicode escapes (`\\65xpression(`), null bytes, or CSS comments (`exp/**/ression(`). These CSS injection vectors only work in legacy browsers (IE6-IE10). SpecifyJS targets modern browsers. Starting in version 0.2.136, CSS sanitization now normalizes unicode escapes and strips CSS comments before pattern matching. Also checks for `behavior:`, `-moz-binding`, and `-o-link` patterns.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"@asymmetric-effort/specifyjs: CSS expression sanitization is bypassable in renderToString","id":"CVE-2026-50290","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"OpenImageIO: Segmentation Fault in BmpInput::read_native_scanline (bmpinput.cpp:399)","id":"CVE-2026-50291"},"packages":[{"ecosystem":"npm","fixed":["0.2.136"],"introduced":["0"],"last_affected":[],"package":"@asymmetric-effort/specifyjs","purl":null,"source":"GHSA-93q6-wwjh-jc6h"},{"ecosystem":"npm","fixed":["0.2.136"],"introduced":["0"],"last_affected":[],"package":"@asymmetric-effort/specifyjs","purl":"pkg:npm/%40asymmetric-effort/specifyjs","source":"GHSA-93q6-wwjh-jc6h"}],"prev":{"headline":"systeminformation: OS command injection in networkInterfaces() via interfaces(5) source-directive path on Linux","id":"CVE-2026-50289"},"products":["specifyjs"],"published":"2026-08-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-21","vendors":["asymmetric-effort"]},"summary":"Attacker can bypass CSS sanitization to inject malicious scripts in legacy browsers, requiring an upgrade to the SpecifyJS library.","url":"https://insights.sbomify.com/CVE-2026-50290/"}