# CVE-2026-50290: @asymmetric-effort/specifyjs: CSS expression sanitization is bypassable in renderToString

> Attacker can bypass CSS sanitization to inject malicious scripts in legacy browsers, requiring an upgrade to the SpecifyJS library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-93q6-wwjh-jc6h

## What is CVE-2026-50290?

CVE-2026-50290 is a medium-severity cross-site scripting vulnerability in asymmetric-effort specifyjs, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

SpecifyJS is a declarative TypeScript user interface framework. Prior to version 0.2.136, CSS value sanitization stripped `expression(` and `url(javascript:` using simple regex, but could be bypassed with CSS unicode escapes (`\65xpression(`), null bytes, or CSS comments (`exp/**/ression(`). These CSS injection vectors only work in legacy browsers (IE6-IE10). SpecifyJS targets modern browsers. Starting in version 0.2.136, CSS sanitization now normalizes unicode escapes and strips CSS comments before pattern matching. Also checks for `behavior:`, `-moz-binding`, and `-o-link` patterns.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-50290?

2 open source packages ship an affected version, including @asymmetric-effort/specifyjs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@asymmetric-effort/specifyjs` | npm | All versions | 0.2.136 |
| `@asymmetric-effort/specifyjs` | npm | All versions | 0.2.136 |

## How do I fix CVE-2026-50290?

Upgrade @asymmetric-effort/specifyjs to 0.2.136 or later.

## Is CVE-2026-50290 being exploited?

There is no known exploitation of CVE-2026-50290 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50290 and fix it if it is affected.

What it is: CVE-2026-50290 is a medium-severity cross-site scripting vulnerability in asymmetric-effort specifyjs, published on 21 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-50290 in the wild and no public exploit code.

Affected packages and fixed versions:
- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136
- @asymmetric-effort/specifyjs (npm): affected all versions; fixed in 0.2.136

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50290/ (Markdown: https://insights.sbomify.com/CVE-2026-50290/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50290
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50290
- OSV: https://osv.dev/vulnerability/CVE-2026-50290

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50290/
Summaries are generated and may contain mistakes; the official description above is the record.
