# CVE-2026-5038: multer vulnerable to Denial of Service via incomplete cleanup of aborted uploads

> An attacker can exhaust disk space by triggering aborted uploads, causing denial of service in applications using multer with diskStorage.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2026
- **Updated:** 15 Jun 2026
- **Also known as:** ECHO-5e3d-8f6c-d17d, GHSA-3p4h-7m6x-2hcm, MINI-4cjj-qmf8-6c6j, ROOT-APP-NPM-CVE-2026-5038

## What is CVE-2026-5038?

CVE-2026-5038 is a medium-severity denial of service vulnerability in multer, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Impact: multer versions 2.0.0-alpha.1 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service when using diskStorage. Aborted or malformed multipart uploads leave orphaned partial files on disk because the Readable.pipe() call does not propagate the stream destroy signal to 
the underlying fs.WriteStream. An attacker can exhaust disk space by triggering many aborted uploads, with no application bug required.

Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease). Both versions track in-flight write streams and clean them up on the abort path.

Workarounds: None.

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2026-5038?

4 open source packages ship an affected version, including multer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `multer` | npm | From 2.0.0-alpha.1 | 2.2.0 |
| `multer` | npm | From 2.0.0-alpha.1 | 2.2.0 |
| `multer` | npm | From 3.0.0-alpha.1 | 3.0.0-alpha.2 |
| `multer` | npm | From 3.0.0-alpha.1 | 3.0.0-alpha.2 |

Products: Expressjs Multer.

## How do I fix CVE-2026-5038?

Upgrade multer to a fixed version for your release line: 2.2.0 or 3.0.0-alpha.2.

## Is CVE-2026-5038 being exploited?

There is no known exploitation of CVE-2026-5038 in the wild and no public exploit code.

## Other vulnerabilities in multer

- [CVE-2026-3520](https://insights.sbomify.com/CVE-2026-3520/): Multer vulnerable to Denial of Service via uncontrolled recursion (high 8.7)
- [CVE-2026-2359](https://insights.sbomify.com/CVE-2026-2359/): Multer vulnerable to Denial of Service via resource exhaustion (high 8.7)
- [CVE-2026-3304](https://insights.sbomify.com/CVE-2026-3304/): Multer vulnerable to Denial of Service via incomplete cleanup (high 8.7)
- [CVE-2026-77037](https://insights.sbomify.com/CVE-2026-77037/): multer vulnerable to Denial of Service via file descriptor leak on aborted uploads (high 7.5)
- [CVE-2026-77078](https://insights.sbomify.com/CVE-2026-77078/): multer vulnerable to Denial of Service via crafted multipart field names (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5038 and fix it if it is affected.

What it is: CVE-2026-5038 is a medium-severity denial of service vulnerability in multer, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-5038 in the wild and no public exploit code.

Affected packages and fixed versions:
- multer (npm): affected from 2.0.0-alpha.1; fixed in 2.2.0
- multer (npm): affected from 2.0.0-alpha.1; fixed in 2.2.0
- multer (npm): affected from 3.0.0-alpha.1; fixed in 3.0.0-alpha.2
- multer (npm): affected from 3.0.0-alpha.1; fixed in 3.0.0-alpha.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5038/ (Markdown: https://insights.sbomify.com/CVE-2026-5038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5038
- OSV: https://osv.dev/vulnerability/CVE-2026-5038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5038/
Summaries are generated and may contain mistakes; the official description above is the record.
