# CVE-2026-50540: Kata Containers: Config Path Annotation Arbitrary File Loading

> An attacker can execute arbitrary code as root on the host by supplying a malicious configuration path annotation to the Kata Containers runtime.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 24 Aug 2026
- **Also known as:** AZL-94610, AZL-94622, AZL-94679, AZL-94682, GHSA-mp2j-xm59-qfgw, OESA-2026-3405, OESA-2026-3653, OESA-2026-3850

## What is CVE-2026-50540?

CVE-2026-50540 is a critical path traversal vulnerability in kata-containers, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kata Containers is an open source project focusing on a standard implementation of lightweight Virtual Machines (VMs) that perform like containers. Prior to version 4.0.0, kata-runtime is vulnerable to host code execution via an unvalidated configuration path annotation. The runtime accepts an arbitrary io.katacontainers.config_path pod annotation and loads the referenced host TOML file without restriction. As a result, a pod user who can place a file at a host-visible path can supply a configuration that selects an attacker-controlled hypervisor or virtio-fs daemon binary, executing code as root on the host. This issue is fixed in version 4.0.0.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-50540?


## How do I fix CVE-2026-50540?

Upgrade to a fixed version.

## Is CVE-2026-50540 being exploited?

There is no known exploitation of CVE-2026-50540 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50540 and fix it if it is affected.

What it is: CVE-2026-50540 is a critical path traversal vulnerability in kata-containers, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50540 in the wild and no public exploit code.

Affected product: kata-containers. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50540/ (Markdown: https://insights.sbomify.com/CVE-2026-50540/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50540
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50540
- OSV: https://osv.dev/vulnerability/CVE-2026-50540

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50540/
Summaries are generated and may contain mistakes; the official description above is the record.
