CVE-2026-50555 @angular/platform-server: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

High 8.6 Published Updated

An XSS vulnerability in Angular's server-side rendering allows attackers to execute arbitrary scripts via crafted Unicode payloads in raw-text elements.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-50555?

CVE-2026-50555 is a high-severity cross-site scripting vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of raw-text elements (such as <script>, <style>, and <iframe>). domino supports escaping raw-text elements during serialization to prevent closing-tag breakout. However, a Unicode index alignment bug existed in this escaping logic. In JavaScript, string lengths and character indices are calculated based on UTF-16 code units (where astral characters—such as emojis—occupy 2 code units / 4 bytes). If the bound dynamic text contained astral Unicode characters before the closing tag (e.g. </script>, </style>, or </iframe>), the index offset calculation in domino's replacement logic shifted. This misalignment caused domino to fail to replace or escape the closing tag, leaving it raw and unescaped in the output HTML. An attacker who controls the dynamic text can supply a payload containing both an astral Unicode character and a closing tag (e.g., 😀</iframe><script>alert(1)</script>). When serialized on the server during SSR, the browser parses the unescaped closing tag, exits the raw-text context early, and executes the subsequent <script> block, leading to same-origin Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25.

Weakness: CWE-79

Which versions are affected by CVE-2026-50555?

10 open source packages ship an affected version, including @angular/platform-server. It affects 1 product.

PackageAffectedFixed in
@angular/platform-server npmAll versions to 18.2.14None
@angular/platform-server npmAll versions to 18.2.14None
@angular/platform-server npmFrom 19.0.0-next.019.2.25
@angular/platform-server npmFrom 19.0.0-next.019.2.25
@angular/platform-server npmFrom 20.0.0-next.020.3.24
@angular/platform-server npmFrom 20.0.0-next.020.3.24
4 more packages
@angular/platform-server npmFrom 21.0.0-next.021.2.16
@angular/platform-server npmFrom 21.0.0-next.021.2.16
@angular/platform-server npmFrom 22.0.0-next.022.0.0-rc.2
@angular/platform-server npmFrom 22.0.0-next.022.0.0-rc.2

Products include Angular Angular.

How do I fix CVE-2026-50555?

Upgrade @angular/platform-server to a fixed version for your release line: 19.2.25, 20.3.24, 21.2.16 or 22.0.0-rc.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-50555 being exploited?

There is no known exploitation of CVE-2026-50555 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-50555, GHSA-hqr9-c56f-3x7f, UBUNTU-CVE-2026-50555.

Is CVE-2026-50555 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free