# CVE-2026-50555: @angular/platform-server: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

> An XSS vulnerability in Angular's server-side rendering allows attackers to execute arbitrary scripts via crafted Unicode payloads in raw-text elements.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-50555, GHSA-hqr9-c56f-3x7f, UBUNTU-CVE-2026-50555

## What is CVE-2026-50555?

CVE-2026-50555 is a high-severity cross-site scripting vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of raw-text elements (such as <script>, <style>, and <iframe>). domino supports escaping raw-text elements during serialization to prevent closing-tag breakout. However, a Unicode index alignment bug existed in this escaping logic. In JavaScript, string lengths and character indices are calculated based on UTF-16 code units (where astral characters—such as emojis—occupy 2 code units / 4 bytes). If the bound dynamic text contained astral Unicode characters before the closing tag (e.g. </script>, </style>, or </iframe>), the index offset calculation in domino's replacement logic shifted. This misalignment caused domino to fail to replace or escape the closing tag, leaving it raw and unescaped in the output HTML. An attacker who controls the dynamic text can supply a payload containing both an astral Unicode character and a closing tag (e.g., 😀</iframe><script>alert(1)</script>). When serialized on the server during SSR, the browser parses the unescaped closing tag, exits the raw-text context early, and executes the subsequent <script> block, leading to same-origin Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-50555?

10 open source packages ship an affected version, including @angular/platform-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/platform-server` | npm | All versions to 18.2.14 | None |
| `@angular/platform-server` | npm | All versions to 18.2.14 | None |
| `@angular/platform-server` | npm | From 19.0.0-next.0 | 19.2.25 |
| `@angular/platform-server` | npm | From 19.0.0-next.0 | 19.2.25 |
| `@angular/platform-server` | npm | From 20.0.0-next.0 | 20.3.24 |
| `@angular/platform-server` | npm | From 20.0.0-next.0 | 20.3.24 |
| `@angular/platform-server` | npm | From 21.0.0-next.0 | 21.2.16 |
| `@angular/platform-server` | npm | From 21.0.0-next.0 | 21.2.16 |
| `@angular/platform-server` | npm | From 22.0.0-next.0 | 22.0.0-rc.2 |
| `@angular/platform-server` | npm | From 22.0.0-next.0 | 22.0.0-rc.2 |

Products: Angular Angular.

## How do I fix CVE-2026-50555?

Upgrade @angular/platform-server to a fixed version for your release line: 19.2.25, 20.3.24, 21.2.16 or 22.0.0-rc.2.

## Is CVE-2026-50555 being exploited?

There is no known exploitation of CVE-2026-50555 in the wild and no public exploit code.

## Other vulnerabilities in angular

- [CVE-2026-68945](https://insights.sbomify.com/CVE-2026-68945/): Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning (high 8.8)
- [CVE-2026-46417](https://insights.sbomify.com/CVE-2026-46417/): Angular: SSRF via Hostname Hijacking in @angular/platform-server (high 8.8)
- [CVE-2026-50168](https://insights.sbomify.com/CVE-2026-50168/): Angular: URL Parser Differential in @angular/platform-server leading to SSRF Allowlist Bypass (high 8.8)
- [CVE-2026-54266](https://insights.sbomify.com/CVE-2026-54266/): Angular: Weak 32-Bit Cache Key Hashing in `HttpTransferCache` Leading to Cross-Request Data Leakage and State Poisoning (high 8.8)
- [CVE-2026-41423](https://insights.sbomify.com/CVE-2026-41423/): Angular: SSRF via protocol-relative and backslash URLs in Angular Platform-Server (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50555 and fix it if it is affected.

What it is: CVE-2026-50555 is a high-severity cross-site scripting vulnerability in angular, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-50555 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/platform-server (npm): affected all versions up to 18.2.14; no fix listed
- @angular/platform-server (npm): affected all versions up to 18.2.14; no fix listed
- @angular/platform-server (npm): affected from 19.0.0-next.0; fixed in 19.2.25
- @angular/platform-server (npm): affected from 19.0.0-next.0; fixed in 19.2.25
- @angular/platform-server (npm): affected from 20.0.0-next.0; fixed in 20.3.24
- @angular/platform-server (npm): affected from 20.0.0-next.0; fixed in 20.3.24
- @angular/platform-server (npm): affected from 21.0.0-next.0; fixed in 21.2.16
- @angular/platform-server (npm): affected from 21.0.0-next.0; fixed in 21.2.16
- @angular/platform-server (npm): affected from 22.0.0-next.0; fixed in 22.0.0-rc.2
- @angular/platform-server (npm): affected from 22.0.0-next.0; fixed in 22.0.0-rc.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50555/ (Markdown: https://insights.sbomify.com/CVE-2026-50555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50555
- OSV: https://osv.dev/vulnerability/CVE-2026-50555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50555/
Summaries are generated and may contain mistakes; the official description above is the record.
