# CVE-2026-50559: Authentication/Authorization Bypass via Advanced Path Normalization Vulnerabilities

> Attackers can bypass HTTP path-based authorization policies in Quarkus by using encoded characters to access protected resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 13 Aug 2026
- **Also known as:** CLEANSTART-2026-LK75271, CLEANSTART-2026-YM07192, ECHO-0e94-4675-6cee, GHSA-qcxp-gm7m-4j5v, MINI-25q9-3gcq-mp9w, MINI-35jv-hh55-vh33, MINI-673w-jf76-x7ff, MINI-6p55-57gp-wmxx, MINI-gfpm-c6q6-q6g6, MINI-r6q3-5c94-w2q5, MINI-rc4v-hm3v-6hph, MINI-vpqv-g8xp-gvg4

## What is CVE-2026-50559?

CVE-2026-50559 is a high-severity authentication bypass vulnerability in quarkusio quarkus, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Quarkus is a Java framework for building cloud-native applications. Prior to versions 3.37.0, 3.36.3, 3.33.2.1, 3.33.3, 3.27.4.1, 3.27.5, and 3.20.6.2, Quarkus HTTP path-based authorization policies can be bypassed using encoded semicolons (%3B) to smuggle matrix parameters past the security layer, and using encoded slashes (%2F) or backslashes (%5C) to access protected static resources. This is a distinct issue from CVE-2026-39852, which addressed only literal semicolon stripping. Versions 3.37.0, 3.36.3, 3.33.2.1, 3.33.3, 3.27.4.1, 3.27.5, and 3.20.6.2 contain a patch.

Weakness: CWE-551 (Incorrect Behavior Order: Authorization Before Parsing and Canonicalization), CWE-863 (Incorrect Authorization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-50559?

10 open source packages ship an affected version, including io.quarkus:quarkus-vertx-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.quarkus:quarkus-vertx-http` | Maven | All versions | 3.20.6.2 |
| `io.quarkus:quarkus-vertx-http` | Maven | All versions | 3.20.6.2 |
| `io.quarkus:quarkus-vertx-http` | Maven | From 3.21.0.CR1 | 3.27.4.1 |
| `io.quarkus:quarkus-vertx-http` | Maven | From 3.21.0.CR1 | 3.27.4.1 |
| `io.quarkus:quarkus-vertx-http` | Maven | From 3.28.0.CR1 | 3.33.2.1 |
| `io.quarkus:quarkus-vertx-http` | Maven | From 3.28.0.CR1 | 3.33.2.1 |
| `io.quarkus:quarkus-vertx-http` | Maven | From 3.34.0.CR1 | 3.36.3 |
| `io.quarkus:quarkus-vertx-http` | Maven | From 3.34.0.CR1 | 3.36.3 |
| `io.quarkus:quarkus-vertx-http` | Maven | From 3.37.0.CR1 | 3.37.0 |
| `io.quarkus:quarkus-vertx-http` | Maven | From 3.37.0.CR1 | 3.37.0 |

Products: Quarkus Quarkus.

## How do I fix CVE-2026-50559?

Upgrade io.quarkus:quarkus-vertx-http to a fixed version for your release line: 3.20.6.2, 3.27.4.1, 3.33.2.1 or 3.36.3.

## Is CVE-2026-50559 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50559 exists.

## Other vulnerabilities in quarkusio quarkus

- [CVE-2022-4116](https://insights.sbomify.com/CVE-2022-4116/): Code injection in quarkus dev ui config editor (critical 9.8)
- [CVE-2022-2466](https://insights.sbomify.com/CVE-2022-2466/): Quarkus does not terminate HTTP requests header context (critical 9.8)
- [CVE-2024-12225](https://insights.sbomify.com/CVE-2024-12225/): Io.quarkus:quarkus-security-webauthn: quarkus webauthn unexpected authentication bypass (critical 9.1)
- [CVE-2026-39852](https://insights.sbomify.com/CVE-2026-39852/): Quarkus authorization bypass via semicolon path normalization inconsistency (high 8.8)
- [CVE-2022-0981](https://insights.sbomify.com/CVE-2022-0981/): Privilege escalation in quarkus (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50559 and fix it if it is affected.

What it is: CVE-2026-50559 is a high-severity authentication bypass vulnerability in quarkusio quarkus, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50559 exists.

Affected packages and fixed versions:
- io.quarkus:quarkus-vertx-http (Maven): affected all versions; fixed in 3.20.6.2
- io.quarkus:quarkus-vertx-http (Maven): affected all versions; fixed in 3.20.6.2
- io.quarkus:quarkus-vertx-http (Maven): affected from 3.21.0.CR1; fixed in 3.27.4.1
- io.quarkus:quarkus-vertx-http (Maven): affected from 3.21.0.CR1; fixed in 3.27.4.1
- io.quarkus:quarkus-vertx-http (Maven): affected from 3.28.0.CR1; fixed in 3.33.2.1
- io.quarkus:quarkus-vertx-http (Maven): affected from 3.28.0.CR1; fixed in 3.33.2.1
- io.quarkus:quarkus-vertx-http (Maven): affected from 3.34.0.CR1; fixed in 3.36.3
- io.quarkus:quarkus-vertx-http (Maven): affected from 3.34.0.CR1; fixed in 3.36.3
- io.quarkus:quarkus-vertx-http (Maven): affected from 3.37.0.CR1; fixed in 3.37.0
- io.quarkus:quarkus-vertx-http (Maven): affected from 3.37.0.CR1; fixed in 3.37.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50559/ (Markdown: https://insights.sbomify.com/CVE-2026-50559/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50559
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50559
- OSV: https://osv.dev/vulnerability/CVE-2026-50559

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50559/
Summaries are generated and may contain mistakes; the official description above is the record.
