CVE-2026-50560 Netty susceptible to HTTP/2 Reset Attack with different on-the-wire signature

Medium 6.9 Published Updated

Netty is vulnerable to a HTTP/2 Reset Attack causing denial of service when handling large header sizes, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-50560?

CVE-2026-50560 is a medium-severity denial of service vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Netty is a network application framework for development of protocol servers and clients. Prior to versions 4.1.135.Final and 4.2.15.Final, Netty HTTP/2 max header size handling produces an attack similar to HTTP/2 Rapid Reset. There is a setting in the http2 specification called `SETTINGS_MAX_HEADER_LIST_SIZE`. When a client sends that setting to Netty, it appears that Netty will behave as follows: read the request; proxy the request to the origin; attempt to produce a response; and create an exception while writing the headers for the response. Functionally, this should be similar to the http2 reset attack, but with a different on-the-wire signature. Versions 4.1.135.Final and 4.2.15.Final patch the issue.

Weakness: CWE-770

Which versions are affected by CVE-2026-50560?

4 open source packages ship an affected version, including io.netty:netty-codec-http2. It affects 1 product.

PackageAffectedFixed in
io.netty:netty-codec-http2 MavenAll versions4.1.135.Final
io.netty:netty-codec-http2 MavenAll versions4.1.135.Final
io.netty:netty-codec-http2 MavenFrom 4.2.0.Final4.2.15.Final
io.netty:netty-codec-http2 MavenFrom 4.2.0.Final4.2.15.Final

Products include Netty Netty.

How do I fix CVE-2026-50560?

Upgrade io.netty:netty-codec-http2 to a fixed version for your release line: 4.1.135.Final or 4.2.15.Final.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-50560 being exploited?

There is no known exploitation of CVE-2026-50560 in the wild and no public exploit code.

All Netty Netty vulnerabilities

Sources

Also known as CLEANSTART-2026-GI68379, CLEANSTART-2026-IP93838, CLEANSTART-2026-JY64777, CLEANSTART-2026-PG06501, CLEANSTART-2026-XZ02009, DEBIAN-CVE-2026-50560 and 78 more.

Is CVE-2026-50560 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free