# CVE-2026-50560: Netty susceptible to HTTP/2 Reset Attack with different on-the-wire signature

> Netty is vulnerable to a HTTP/2 Reset Attack causing denial of service when handling large header sizes, requiring an upgrade to patched versions.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 13 Jun 2026
- **Also known as:** CLEANSTART-2026-GI68379, CLEANSTART-2026-IP93838, CLEANSTART-2026-JY64777, CLEANSTART-2026-PG06501, CLEANSTART-2026-XZ02009, DEBIAN-CVE-2026-50560, ECHO-cbaf-eeb2-8e8f, GHSA-563q-j3cm-6jxm, MINI-246m-x8j2-h773, MINI-28cw-wxv6-8242, MINI-29mp-c84q-fcrj, MINI-2hfc-w33h-9w7q, MINI-35p8-vr26-g363, MINI-363v-pxq9-vwvm, MINI-377g-6gvq-q932, MINI-3j9r-7pf8-hj8r, MINI-3qxj-m544-8crx, MINI-3r3m-hmhg-vpvh, MINI-3w8m-pj99-45f3, MINI-493p-77gc-mgv3, MINI-57f5-gv43-cc3x, MINI-5f42-c372-rpwq, MINI-5mvv-94r6-wx2x, MINI-5rx3-5w6w-54j6, MINI-5xrf-g7gw-vh4m, MINI-6464-3xfv-2vcj, MINI-6g7p-m9h3-wgm7, MINI-75pf-6xw6-7r69, MINI-77j4-h7gr-9g7q, MINI-784x-9pwm-6mf2, MINI-88pr-vp72-x7mq, MINI-8ghf-94j6-h2g6, MINI-8mx4-r7hm-vmx6, MINI-94qc-93jm-x749, MINI-97r5-g3vf-wfhr, MINI-9g63-c82v-j655, MINI-9j3r-745j-86gj, MINI-c4h5-8cvv-hwp4, MINI-c9qq-g9qm-49cq, MINI-cc2q-9h9c-fc54, MINI-cc84-f7p2-3833, MINI-cj3q-p274-g7fj, MINI-cpmh-xg94-5qm6, MINI-ff7j-crfp-949j, MINI-fg96-x9wx-jqpv, MINI-fgw6-mfxr-3qh7, MINI-fp3m-9w5h-qcmj, MINI-g2q9-wvfq-6hfv, MINI-g497-jj4r-3wcx, MINI-g7vp-g3v4-xrcm, MINI-h548-c4fv-fjvm, MINI-hg4c-xx39-crwh, MINI-hhmr-p6wc-cw6p, MINI-j2v3-2gwp-v2f3, MINI-j4hw-qmpm-xv7w, MINI-jcvv-3c2r-gvqq, MINI-jfxv-7373-v7xg, MINI-jj9w-g95v-h8mm, MINI-jxpm-2w5p-9gfx, MINI-m3q4-wc8f-jfxc, MINI-m6xh-36vv-55fm, MINI-m9qv-4vh9-9wcf, MINI-mgh7-3p64-mjpq, MINI-mmf7-8rcj-h6x3, MINI-mwwm-2259-j7g7, MINI-p5c9-wwpg-6hrq, MINI-p6f8-cv59-fwqr, MINI-pfr7-42fv-q3v9, MINI-pmrx-5wx5-8x46, MINI-q24q-h5m5-42m8, MINI-qfr7-7gr8-46j4, MINI-qjrr-vfvf-fxf3, MINI-vg45-xvxq-c8wq, MINI-vp3q-xpwq-fwmj, MINI-w5rj-phg2-243j, MINI-w7mq-786h-72pj, MINI-wfhh-c2cf-rj37, MINI-wgwv-74vv-pwmf, MINI-wmrj-c485-5885, MINI-x5mf-247p-88qr, MINI-x727-x23j-2xf3, MINI-xr5r-4r3m-x2x7, ROOT-APP-MAVEN-CVE-2026-50560, UBUNTU-CVE-2026-50560

## What is CVE-2026-50560?

CVE-2026-50560 is a medium-severity denial of service vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is a network application framework for development of protocol servers and clients. Prior to versions 4.1.135.Final and 4.2.15.Final, Netty HTTP/2 max header size handling produces an attack similar to HTTP/2 Rapid Reset. There is a setting in the http2 specification called `SETTINGS_MAX_HEADER_LIST_SIZE`. When a client sends that setting to Netty, it appears that Netty will behave as follows: read the request; proxy the request to the origin; attempt to produce a response; and create an exception while writing the headers for the response. Functionally, this should be similar to the http2 reset attack, but with a different on-the-wire signature. Versions 4.1.135.Final and 4.2.15.Final patch the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-50560?

4 open source packages ship an affected version, including io.netty:netty-codec-http2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http2` | Maven | All versions | 4.1.135.Final |
| `io.netty:netty-codec-http2` | Maven | All versions | 4.1.135.Final |
| `io.netty:netty-codec-http2` | Maven | From 4.2.0.Final | 4.2.15.Final |
| `io.netty:netty-codec-http2` | Maven | From 4.2.0.Final | 4.2.15.Final |

Products: Netty Netty.

## How do I fix CVE-2026-50560?

Upgrade io.netty:netty-codec-http2 to a fixed version for your release line: 4.1.135.Final or 4.2.15.Final.

## Is CVE-2026-50560 being exploited?

There is no known exploitation of CVE-2026-50560 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50560 and fix it if it is affected.

What it is: CVE-2026-50560 is a medium-severity denial of service vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50560 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-http2 (Maven): affected all versions; fixed in 4.1.135.Final
- io.netty:netty-codec-http2 (Maven): affected all versions; fixed in 4.1.135.Final
- io.netty:netty-codec-http2 (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final
- io.netty:netty-codec-http2 (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50560/ (Markdown: https://insights.sbomify.com/CVE-2026-50560/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50560
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50560
- OSV: https://osv.dev/vulnerability/CVE-2026-50560

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50560/
Summaries are generated and may contain mistakes; the official description above is the record.
