# CVE-2026-50576: ePA 3.x Integration: HTTP Header Injection in VAU Inner Requests

> An authenticated attacker can inject CRLF characters to manipulate HTTP headers, potentially exposing patient records or bypassing authentication in ePA integrations.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-j8jg-7fqf-4xx9

## What is CVE-2026-50576?

CVE-2026-50576 is a medium-severity vulnerability in fbeta-GmbH ePA3-Service-OpenSource, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ePA 3.x Integration implements the authorization workflow and writes Medical Information Objects to Germany's electronic patient record. Prior to 1.3.0, ePA 3.x Integration does not neutralize CRLF characters in values used by app/vau/VAUProtokoll.py to construct VAU inner HTTP requests. The build_inner_header function interpolates the uri, host, accept_type, content_type, content_length, USER_AGENT, and insurant_id values into request lines and headers, including x-useragent and x-insurantid. An authenticated attacker who controls a value can inject additional headers into the inner request. Depending on ePA server handling, an injected x-insurantid header can expose another patient's records, and injected Authorization headers can bypass the intended authentication or authorization context. Session-derived USER_AGENT input can also poison requests across the session. This issue is fixed in version 1.3.0.

Weakness: CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-50576?


## How do I fix CVE-2026-50576?

No fix has been published for CVE-2026-50576 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-50576 being exploited?

There is no known exploitation of CVE-2026-50576 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50576 and fix it if it is affected.

What it is: CVE-2026-50576 is a medium-severity vulnerability in fbeta-GmbH ePA3-Service-OpenSource, published on 18 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50576 in the wild and no public exploit code.

Affected product: fbeta-GmbH ePA3-Service-OpenSource. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50576/ (Markdown: https://insights.sbomify.com/CVE-2026-50576/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50576
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50576
- OSV: https://osv.dev/vulnerability/CVE-2026-50576

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50576/
Summaries are generated and may contain mistakes; the official description above is the record.
