{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-50578 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-50578 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-50578 is a high-severity vulnerability in fbeta-GmbH ePA3-Service-OpenSource, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-50578 and fix it if it is affected.\n\nWhat it is: CVE-2026-50578 is a high-severity vulnerability in fbeta-GmbH ePA3-Service-OpenSource, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-50578 in the wild and no public exploit code.\n\nAffected product: fbeta-GmbH ePA3-Service-OpenSource. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-50578/ (Markdown: https://insights.sbomify.com/CVE-2026-50578/index.md)","id":"CVE-2026-50578","markdown":"https://insights.sbomify.com/CVE-2026-50578/index.md","name":"CVE-2026-50578","record":{"aliases":["GHSA-j9m9-pmwv-hwwr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"ePA integration library","requires_auth":"none","summary":"An attacker can intercept ePA traffic and observe smartcard operations by bypassing disabled TLS certificate verification in the integration library.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"ePA 3.x Integration implements the authorization workflow and writes Medical Information Objects to Germany's electronic patient record. Prior to 1.3.0, ePA 3.x Integration disables TLS certificate verification for both ePA connections in app/vau/VAUProtokoll.py and Konnektor connections in app/konnektor/Konnektor.py. A network-positioned attacker can present an arbitrary certificate, terminate the TLS connection, and intercept ePA traffic. The VAU protocol does not provide an effective fallback because its application-layer certificate validation is also broken in affected versions. The Konnektor session uses self.session.verify set to False while the client authenticates with self.session.cert, so an attacker impersonating the Konnektor can receive the client's mutual TLS certificate exchange and observe smartcard operations. This issue is fixed in version 1.3.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"ePA 3.x Integration: TLS Certificate Verification Universally Disabled","id":"CVE-2026-50578","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":0,"n_references":5,"next":{"headline":"OpenStack Ironic: Crafted JSON String to Certain Endpoints on the API or JSON-RPC Service May Result in Service Crash","id":"CVE-2026-50589"},"packages":[],"prev":{"headline":"ePA 3.x Integration: AES-GCM Nonce Reuse via Frozen VAU Request Counter","id":"CVE-2026-50577"},"products":["ePA3-Service-OpenSource"],"published":"2026-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-18","vendors":["fbeta-GmbH"]},"summary":"An attacker can intercept ePA traffic and observe smartcard operations by bypassing disabled TLS certificate verification in the integration library.","url":"https://insights.sbomify.com/CVE-2026-50578/"}