# CVE-2026-50578: ePA 3.x Integration: TLS Certificate Verification Universally Disabled

> An attacker can intercept ePA traffic and observe smartcard operations by bypassing disabled TLS certificate verification in the integration library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-j9m9-pmwv-hwwr

## What is CVE-2026-50578?

CVE-2026-50578 is a high-severity vulnerability in fbeta-GmbH ePA3-Service-OpenSource, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ePA 3.x Integration implements the authorization workflow and writes Medical Information Objects to Germany's electronic patient record. Prior to 1.3.0, ePA 3.x Integration disables TLS certificate verification for both ePA connections in app/vau/VAUProtokoll.py and Konnektor connections in app/konnektor/Konnektor.py. A network-positioned attacker can present an arbitrary certificate, terminate the TLS connection, and intercept ePA traffic. The VAU protocol does not provide an effective fallback because its application-layer certificate validation is also broken in affected versions. The Konnektor session uses self.session.verify set to False while the client authenticates with self.session.cert, so an attacker impersonating the Konnektor can receive the client's mutual TLS certificate exchange and observe smartcard operations. This issue is fixed in version 1.3.0.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-50578?


## How do I fix CVE-2026-50578?

No fix has been published for CVE-2026-50578 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-50578 being exploited?

There is no known exploitation of CVE-2026-50578 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50578 and fix it if it is affected.

What it is: CVE-2026-50578 is a high-severity vulnerability in fbeta-GmbH ePA3-Service-OpenSource, published on 18 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-50578 in the wild and no public exploit code.

Affected product: fbeta-GmbH ePA3-Service-OpenSource. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50578/ (Markdown: https://insights.sbomify.com/CVE-2026-50578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50578
- OSV: https://osv.dev/vulnerability/CVE-2026-50578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50578/
Summaries are generated and may contain mistakes; the official description above is the record.
