CVE-2026-5079 multer vulnerable to Denial of Service via deeply nested field names
An attacker can cause denial of service in applications using multer by sending multipart data with deeply nested field names, exhausting server resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-5079?
CVE-2026-5079 is a high-severity denial of service vulnerability in multer, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this.
Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires.
Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.
Weakness: CWE-400
Which versions are affected by CVE-2026-5079?
4 open source packages ship an affected version, including multer. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
multer npm | From 1.0.0 | 2.2.0 |
multer npm | From 1.0.0 | 2.2.0 |
multer npm | From 3.0.0-alpha.1 | 3.0.0-alpha.2 |
multer npm | From 3.0.0-alpha.1 | 3.0.0-alpha.2 |
Products include Expressjs Multer.
How do I fix CVE-2026-5079?
Upgrade multer to a fixed version for your release line: 2.2.0 or 3.0.0-alpha.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-5079 being exploited?
There is no known exploitation of CVE-2026-5079 in the wild and no public exploit code.
Other vulnerabilities in multer
- CVE-2026-3520 Multer vulnerable to Denial of Service via uncontrolled recursion
- CVE-2026-2359 Multer vulnerable to Denial of Service via resource exhaustion
- CVE-2026-3304 Multer vulnerable to Denial of Service via incomplete cleanup
- CVE-2026-77037 multer vulnerable to Denial of Service via file descriptor leak on aborted uploads
- CVE-2026-77078 multer vulnerable to Denial of Service via crafted multipart field names
Sources
Also known as CLSA-2026-1784077507, ECHO-f70f-5c59-82fe, GHSA-72gw-mp4g-v24j, MINI-7xr7-35g3-9mpw, MINI-p5qv-w9q8-hhqf, ROOT-APP-NPM-CVE-2026-5079.