{"answers":{"affected":"4 open source packages ship an affected version, including multer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-5079 in the wild and no public exploit code.","fix":"Upgrade multer to a fixed version for your release line: 2.2.0 or 3.0.0-alpha.2.","what":"CVE-2026-5079 is a high-severity denial of service vulnerability in multer, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-5079 and fix it if it is affected.\n\nWhat it is: CVE-2026-5079 is a high-severity denial of service vulnerability in multer, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-5079 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- multer (npm): affected from 1.0.0; fixed in 2.2.0\n- multer (npm): affected from 1.0.0; fixed in 2.2.0\n- multer (npm): affected from 3.0.0-alpha.1; fixed in 3.0.0-alpha.2\n- multer (npm): affected from 3.0.0-alpha.1; fixed in 3.0.0-alpha.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-5079/ (Markdown: https://insights.sbomify.com/CVE-2026-5079/index.md)","id":"CVE-2026-5079","markdown":"https://insights.sbomify.com/CVE-2026-5079/index.md","name":"CVE-2026-5079","record":{"aliases":["CLSA-2026-1784077507","ECHO-f70f-5c59-82fe","GHSA-72gw-mp4g-v24j","MINI-7xr7-35g3-9mpw","MINI-p5qv-w9q8-hhqf","ROOT-APP-NPM-CVE-2026-5079"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js file upload library","requires_auth":"none","summary":"An attacker can cause denial of service in applications using multer by sending multipart data with deeply nested field names, exhausting server resources.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"multer","vendor":"expressjs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this.\n\nPatches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires.\n\nWorkarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"multer vulnerable to Denial of Service via deeply nested field names","id":"CVE-2026-5079","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"Dancer::Session::Abstract versions through 1.3522 for Perl generates session ids insecurely","id":"CVE-2026-5080"},"packages":[{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["1.0.0"],"last_affected":[],"package":"multer","purl":null,"source":"GHSA-72gw-mp4g-v24j"},{"ecosystem":"npm","fixed":["2.2.0"],"introduced":["1.0.0"],"last_affected":[],"package":"multer","purl":"pkg:npm/multer","source":"GHSA-72gw-mp4g-v24j"},{"ecosystem":"npm","fixed":["3.0.0-alpha.2"],"introduced":["3.0.0-alpha.1"],"last_affected":[],"package":"multer","purl":null,"source":"GHSA-72gw-mp4g-v24j"},{"ecosystem":"npm","fixed":["3.0.0-alpha.2"],"introduced":["3.0.0-alpha.1"],"last_affected":[],"package":"multer","purl":"pkg:npm/multer","source":"GHSA-72gw-mp4g-v24j"}],"prev":{"headline":"morgan vulnerable to Log Forging via unneutralized control characters in :remote-user","id":"CVE-2026-5078"},"products":["multer"],"published":"2026-06-15","related":[{"cvss_score":8.7,"headline":"Multer vulnerable to Denial of Service via uncontrolled recursion","id":"CVE-2026-3520","kev_date_added":null,"published":"2026-03-04"},{"cvss_score":8.7,"headline":"Multer vulnerable to Denial of Service via resource exhaustion","id":"CVE-2026-2359","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":8.7,"headline":"Multer vulnerable to Denial of Service via incomplete cleanup","id":"CVE-2026-3304","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via file descriptor leak on aborted uploads","id":"CVE-2026-77037","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via crafted multipart field names","id":"CVE-2026-77078","kev_date_added":null,"published":"2026-08-28"},{"cvss_score":7.5,"headline":"multer vulnerable to Denial of Service via oversized array index in field names","id":"CVE-2026-82333","kev_date_added":null,"published":"2026-08-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-15","vendors":["multer"]},"summary":"An attacker can cause denial of service in applications using multer by sending multipart data with deeply nested field names, exhausting server resources.","url":"https://insights.sbomify.com/CVE-2026-5079/"}