# CVE-2026-50888: Koillection has an authenticated Server-Side Request Forgery issue

> Authenticated attackers can scan internal resources via SSRF in Koillection's custom scraper, requiring an upgrade to mitigate.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2026
- **Updated:** 16 Jun 2026
- **Also known as:** GHSA-gmxh-hjfv-qc2w

## What is CVE-2026-50888?

CVE-2026-50888 is a high-severity server-side request forgery vulnerability in n/a, published on 15 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authenticated Server-Side Request Forgery (SSRF) in the custom scraper subsystem component of Benjamin Jonard Koillection v1.8.0 allows attackers to scan internal resources via supplying a crafted URL.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-50888?

2 open source packages ship an affected version, including koillection/koillection.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `koillection/koillection` | Packagist | All versions | 1.8.4 |
| `koillection/koillection` | Packagist | All versions | 1.8.4 |

## How do I fix CVE-2026-50888?

Upgrade koillection/koillection to 1.8.4 or later.

## Is CVE-2026-50888 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50888 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-50888 and fix it if it is affected.

What it is: CVE-2026-50888 is a high-severity server-side request forgery vulnerability in n/a, published on 15 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-50888 exists.

Affected packages and fixed versions:
- koillection/koillection (Packagist): affected all versions; fixed in 1.8.4
- koillection/koillection (Packagist): affected all versions; fixed in 1.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-50888/ (Markdown: https://insights.sbomify.com/CVE-2026-50888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-50888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-50888
- OSV: https://osv.dev/vulnerability/CVE-2026-50888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-50888/
Summaries are generated and may contain mistakes; the official description above is the record.
